Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,753
Community Members
 
Community Events
168
Community Groups

Error when attaching files: JIRA could not attach the file as there was a missing token.

Hi All,

We have a user who's unable to attach files to JIRA issues and receives the following errors when she tries:

-----------------------------------------

File "<<filename.ext>>" was not uploaded

JIRA could not attach the file as there was a missing token. Please try attaching the file again

-----------------------------------------

She's tried in various browsers, on various issues and with different file types (.jpg, .pdf, .png) and gets the same error every time. It doesn't matter how long she's been logged in to JIRA, and she's tried clearing her cache. Still no joy.

Any thoughts?

Many thanks,

Jodie

5 answers

1 accepted

2 votes
Answer accepted

You already excluded the size of the attachment as the source of this error?

Eventually, this post can help further.

Hi @Thomas Deiler, thanks for the reply. Yep, file size has already been ruled out. It's happening with all file formats from approx. 11kB upwards.

Will have a look at the HAR file option. Thank you for the input.

Like Deleted user likes this
Thomas Deiler Community Leader Feb 14, 2018

@Patrick_Jonas, welcome for what?

Thomas Deiler Community Leader Feb 19, 2018

Dear @jhaughton,

have you meanwhile fixed your problem?

So long

Thomas

Like Deleted user likes this

I had to refresh the Jira page and it worked. Maybe the Jira session had timed out. Also, trying to login again would fix it. 

0 votes

Disabling cache in dev tools did not work in my user's case. She was able to upload the file after creating the issue/task - so there is at least a work around on my side.

Suffering this constantly on up to date Firefox, very disgusting. Any open bug about it? I cannot think about restaring sessions all the time

Hi @Thomas Deiler,

Unfortunately not. When I went to get the HAR file from the user's machine it magically started working again!! It turns out that when the 'Disable Cache' option is checked in Chrome Dev Tools she can attach files with no issue. But as soon as this is unticked again in a new browser session it fails again.

The curious thing is that the attachments failing happens with *all* browsers, so it can't just be a Chrome cache issue.

I'm not sure how much use a HAR file will be if I try and get it without checking Disable Cache (as advised here), but getting that and sending it off to Atlassian is the only thing I can think of at the moment.

Any additional wisdom or ideas would be much appreciated...because this has me totally stumped.

Many thanks,

Jodie

Thomas Deiler Community Leader Feb 20, 2018

Dear @jhaughton,

sound's like an issue for Atlassian. They are supporting Chrome so eventually they can fix around. 

So long

Thomas

Like Yunki Lee likes this

Hi @Thomas Deiler

Just to provide a bit of closure on this one...we tried the same user on my machine and there were no issues, so it's looking more like an issue with her laptop build than anything else. I've handed the ticket over to our Desktop Support guys who, if they can't work out the issue, will be doing a rebuild. So, it's not really a solution, but it's as close as we're going to get for now.

Thank you for your efforts...genuinely appreciated,

Jodie

Like Z B likes this

Did they have to rebuild? We’ve just found your article as we’ve had the same issue! 

I have same issue, has this been fixed now? error.jpg

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Online AMA this week: Your project management questions answered by Jira Design Lead James Rotanson

We know that great teams require amazing project management chops. It's no surprise that great teams who use Jira have strong project managers, effective workflows, and secrets that bring planning ...

164 views 1 6
Read article

Atlassian Community Events