The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

"Log in" Issue when one of directory works incorrectly

Sergey Subbotin
November 8, 2019

Dear Community,

In our company the following user directories for authentication are used in Jira:

  • domain1.com (Microsoft Active Directory)
  • domain2.com (Microsoft Active Directory)
  • Jira Internal Directory

The domain2.com Domain Controller has frozen with no error this weekend. Then users of all the other directories hadn’t an opportunity to log on to Jira as long as the domain2.com Domain Controller started working correctly. Jira restart couldn’t help to solve the problem. Even Jira Internal users couldn’t log on to Jira. The application was working (the webpage was opened) before the authorization. During an authentication attempt the application has frozen on login and failed with timeout error.

The log-files that indicate error:

2019-11-02 14:19:09,182 http-nio-8083-exec-34 ERROR anonymous 856x1919x40 1m21eq 10.10.10.1,127.0.0.1 /rest/usermanagement/1/authentication [c.a.c.manager.application.ApplicationServiceGeneric] Directory 'Domain2' is not functional during authentication of 'example-user'. Skipped.

 Is that typical for authorization process when problems arise at one of connected directories? Is there a way we can avoid such a situation but to configure access to the user directory through a proxy?

We look forward to your reply.

Many thanks!

0 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.