The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

When starting Jira service we get https-openssl-nio-8443-exec-10 error

Divya G
August 6, 2025

We restarted Jira service after patching. While starting the service we get below error. Installed SSL is still valid, even we renewed SSL but still facing issue.

2025-08-06 11:00:56,492-0400 https-openssl-nio-8443-exec-10 ERROR [c.a.j.web.servlet.InternalServerErrorServlet] {errorId=85f141bd-591d-478b-b914-ccaf9d8528e9, interpretedMsg=, cause=java.lang.UnsatisfiedLinkError: 'java.lang.String org.apache.tomcat.jni.SSL.getNextProtoNegotiated(long)', stacktrace=java.lang.UnsatisfiedLinkError: 'java.lang.String org.apache.tomcat.jni.SSL.getNextProtoNegotiated(long)'
at org.apache.tomcat.jni.SSL.getNextProtoNegotiated(Native Method) [tomcat-jni.jar:8.5.78]
at org.apache.tomcat.util.net.openssl.OpenSSLEngine$OpenSSLSession.getProtocol(OpenSSLEngine.java:1427) [tomcat-coyote.jar:8.5.78]
at org.apache.tomcat.util.net.jsse.JSSESupport.getProtocol(JSSESupport.java:213) [tomcat-coyote.jar:8.5.78]
at org.apache.coyote.AbstractProcessor.populateSslRequestAttributes(AbstractProcessor.java:803) [tomcat-coyote.jar:8.5.78]
at org.apache.coyote.AbstractProcessor.action(AbstractProcessor.java:496) [tomcat-coyote.jar:8.5.78]
at org.apache.coyote.Request.action(Request.java:518) [tomcat-coyote.jar:8.5.78]
at org.apache.catalina.connector.Request.getAttribute(Request.java:928) [catalina.jar:8.5.78]
at org.apache.catalina.connector.Request.getAttributeNames(Request.java:1005) [catalina.jar:8.5.78]
at org.apache.catalina.connector.RequestFacade.getAttributeNames(RequestFacade.java:298) [catalina.jar:8.5.78]
at javax.servlet.ServletRequestWrapper.getAttributeNames(ServletRequestWrapper.java:94) [servlet-api.jar:3.1.FR]
at com.atlassian.analytics.client.filter.AbstractHttpFilter.setB3TraceId(AbstractHttpFilter.java:48) [?:?]
at com.atlassian.analytics.client.filter.JiraAnalyticsFilter.doFilter(JiraAnalyticsFilter.java:26) [?:?]
at com.atlassian.analytics.client.filter.AbstractHttpFilter.doFilter(AbstractHttpFilter.java:33) [?:?]
at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter.doFilter(DelegatingPluginFilter.java:62) [atlassian-plugins-servlet-5.5.8.jar:?]
at com.atlassian.plugin.servlet.filter.IteratingFilterChain.doFilter(IteratingFilterChain.java:37) [atlassian-plugins-servlet-5.5.8.jar:?]
at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter.lambda$doFilter$0(DelegatingPluginFilter.java:57) [atlassian-plugins-servlet-5.5.8.jar:?]


Please help in fixing this

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

3 votes
Answer accepted
Brant Schroeder
Community Champion
August 7, 2025

@Divya G Have you submitted a support request to Atlassian.  By providing them with the support zip file they will be able to look at more than just a snippet from your log file.  

If you have and you are waiting for help can you provide additional information like what version did you upgrade from and to?  Are you a single node instance?  What server OS are you on?

Divya G
August 7, 2025

Hi @Brant Schroeder

Thank you. Raised a ticket to Atlassian vendor and Issue got fixed. Recent server patching have upgraded the OpenSSL version compatible with the Tomcat native libraries. As per Atlassian suggestion made few updates in server.xml file and it worked.

Brant Schroeder
Community Champion
August 7, 2025

Great to hear it was resolved.  If you can mark this as accepted that will help others if they have the same error.

DEPLOYMENT TYPE
SERVER
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events