The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

How do I resolve the Tomcat missconfigured error

Ken Weinstein
July 11, 2021

I just upgraded my Jira Software to the latest Long term release, 8.13.8 from 7.x.  On startup I get the dreaded Setup: Tomcat is misconfigured.  I've added the special character code to the server.xml file.  See code below. 

I'm also getting an error Upgrade: Custom changes have not been carried over.  But I did try to just copy the changes and not the whole file.  Not sure where I went wrong.

Any help would be appreciated.

<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
                   maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
                   maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
                   acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https"
                   proxyName="x.x.com" proxyPort="443"/>

<Connector port="8081" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
  URIEncoding="UTF-8" acceptCount="10" connectionTimeout="20000" enableLookups="false"
  maxThreads="200" minSpareThreads="10" />

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

1 vote
Answer accepted
Ken Weinstein
July 11, 2021

I believe I resolved my issue.  I copied over a new server.xml file.  only changed the few lines of code that needed to be changed.  Rebooted and the error went away.  

DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events