The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 

Error because of deleted users selected as custom field value

Pierre Cattin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
October 10, 2013

Hi,

When I re-index jira, I get many error similar to the following (only the usernames are different):

2013-10-10 15:53:27,220 indexerPool-1-thread-10 WARN [issue.customfields.impl.AbstractSingleFieldType] Value stored in database is invalid

com.atlassian.jira.issue.customfields.impl.FieldValidationException: User 'clangmeier' was not found in the system

It seems that it's because of deleted users that are still stored as a customfield value in the database. In Jira interface, the custom fields containing deleted users appear empty.

The database integrity checker doesn't find errors. Is there another way to solve that problem than manually delete the users in the database?

2 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

1 vote
Answer accepted
Florin Manaila
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
October 10, 2013

It's just a warning, not an error and it is normal if you delete the user that is contained in a custom field.

As a rule of thumb, users should not be deleted from JIRA, but rather deactivated ( https://confluence.atlassian.com/display/JIRA/Managing+Users#ManagingUsers-Deactivatingauser )

Removing the custom field values that store deleted users from the database and re-indexing should solve the problem.

0 votes
RambanamP
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
October 10, 2013
Pierre Cattin
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
October 10, 2013

The problem is not the same, those customfields don't have a default value.

I will try to delete the problematic values in the database.

TAGS
AUG Leaders

Atlassian Community Events