The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
  • Community
  • Q&A
  • Jira
  • Questions
  • Erratic behaviour including Pie Charts not displaying, difficulty with attachments and System information unavailable

Erratic behaviour including Pie Charts not displaying, difficulty with attachments and System information unavailable

Manohar Venkataraman
Contributor
May 27, 2014

I'm adding this as a question/answer so that anyone else frantically trying to figure out what the issues mean know how to resolve it.

The following erratic symptoms appear:

1. Only the Pie Chart gadget does not appear on the dashboards. Instead it displays the error message 'An internal server error occurred when requesting resource.'

2. Some users are unable to attach files to issues

3. Clicking through some links on the 'System' menu shows some errors such as 'Not found (404) /secure/admin/views/configurewhitelist.jsp'. Could not find what you were looking for. Maybe you should raise an issue.

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

1 vote
Answer accepted
Manohar Venkataraman
Contributor
May 27, 2014

All the erratic issues could be tracked back to the fact our log files (in particular catalina.out) had grown so large that there wasn't enough space on the File Server. Once I deleted some logs things started to work again, and then I requested Infrastructure to add more file space.

Manohar Venkataraman
Contributor
May 28, 2014

Sorry I disagree. I've been a Jira user for awhile, and it was hard to figure out that these seemingly disparate issues that were suddenly happening were all related to the same cause, which was the system running out of space in the back end. Maybe there was something buried in the catalina.out, but ours was quite large and hard to access in the Production environment.

I'm pretty sure that telling someone to immediately check file space on seeing some of these issues is going to save someone a lot of the time that I spent this morning. I'm posting this to help the next person resolve this issue quickly, because I've already resolved my issue.

Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
May 28, 2014

And what about the other potential causes?

Sorry, but this is a very incomplete answer to this question, and frankly, "read your log" is the first answer as it is for most error symptoms.

Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
May 28, 2014

Mmm. You can disagree all you like, but you're wrong.

You're saying that "jump on one particular random answer that may be right but could be a whole host of other things, and you could end up spending hours chasing completely the wrong thing". In my experience (not particularly Jira, but all software, and a lot of other stuff) it's better to say "read the log file, as it's likely to give you the correct answer first time"

In this case, your system could also have run of of file handles, disk allocation as opposed to physical space, run into a permissions problem, a failed SAN, an unexpectedy unmounted disk, or or or or or... Some of those wouldn't even tell you if you looked at disk space. But the log file is very likely to tell you the right answer. Not a misleading one.

I ran straight into this yesterday. Client had a problem, client had assumed it was X, but hadn't read the log. X was completely wrong (not at all a bad guess, but wrong. And the log file pointed at the right answer immediately)