The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 

Configuring LDAP-based directory with redundancy

Mikhail T
Contributor
April 24, 2014

Hello!

The hostname (ldap.example.com) that we used, when configuring JIRA's user-directory, resolves to several IP-addresses -- we run several replicas for load-sharing and redundancy.

Today we had a problem with one of the replicas and JIRA began having intermittent problems of its own with logins. The error, showing under "Technical Details" of JIRA's apologetic error-page was "Connection Refused".

This surprised me, because I expected JIRA to go through all IPs returned by gethostbyname() -- not give up after failing to connect to the first address on the list.

Is there a way to configure the directory in JIRA to make the LDAP connectivity reliably survive an outage of one of the LDAP-servers? A downed LDAP-server may still introduce a delay (although JIRA could try connecting to all IPs in parallel), but, as long as one of the LDAP-servers remains up and reachable, the user should not get an error...

Perhaps, I can somehow list multiple ldap.url-fields for the same directory? Thanks!

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Answer accepted
Tiago Comasseto
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
April 24, 2014

Hi Mikhail, JIRA currently does not support LDAP failover. From JIRA point of view ldap.example.comis a single host and in the event of a connection failure, JIRA won't try other IPs.

Additionally, there is an improvement request already opened for this here. You may add yourself as watcher and include your comments there.

Cheers

Mikhail T
Contributor
April 27, 2014

Thanks Tiago. Sadly, the ticket you linked to is 3.5 years old, has 42 votes, and yet it still has no assignee. I don't think, I can add much to it -- people have said all the right things back then.

It is rather disappointing. Had this been an open-source software package, I would've added the feature myself over the weekend...

Like • Sander Cornelissen likes this