現象
- 従来は正常に動作していた検索クエリが期待する結果を返さなくなった。特に日本語の3文字以上の検索クエリで結果がおかしい。
対象
- CJK (Chinese, Japanese, Korean) のマルチバイト文字でチケットを検索するケース
原因
直近のクラウド環境のミドルウェア構成変更の影響により、従来は必要なかった設定が求められるようになったことで期待通りに検索結果が表示できなくなっていることが疑われます。
対策
次の手順でインデクシング言語設定の変更をお試しください。
- 管理者としてログインする
- Settingsページ https://__EXAMPLE__.atlassian.net/secure/admin/EditApplicationProperties!default.jspa > Indexing language にて "Chinese/Japanese/Korean" を選択して Update ボタンで反映させる
- 設定変更後インデックスは自動で更新されるので、一定時間待つ(サイズによって処理時間は異なります)

その他、不明点などがあればコメントをお願いします。
0 comments