Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot Complete Sprint in Next-Gen

Unable to complete a sprint - getting the message: "Something's gone wrong - refresh the page and try again". 

Happening on both board and backlog.

5 answers

1 accepted

0 votes
Answer accepted
Julien Femia Atlassian Team Jul 03, 2019

Hey @Brian VanArsdale,

I'm sorry the error message is not a bit more explicit and informative at the moment. We're working on making this better.

Do you have any incomplete subtasks in one of the issues in your project? That would prevent you from completing the sprint... Another thing that could prevent you from completing the sprint is permissions. Make sure you have the "managing issues" permissions on the project.

On a side note, If you open your console's network tab before trying to complete your sprint, you should see the error message that the API is returning. If you're affected by the above issue, you'll see something like this in the response:

Sprint cannot be completed as there are incomplete subtasks on following issues: xxx-xx

where xxx-xx is the parent issue(s) containing the incomplete subtasks.

Let me know if this helps!

0 votes
Nick Atlassian Team Jul 01, 2019

Hi Brian, 

 

Are you still getting such an error ? I have just tried to reproduce this and can not.

If you are still getting an error when completing a sprint, can you please raise a support request at https://getsupport.atlassian.com

 

Regards

Nick

Hi,

I am also facing the same issue, was  able to complete the sprint earlier,but now its not working and getting the error:-

"Something's gone wrong - refresh the page and try again". 

Have checked all the subtask they  are in complete state.

Please suggest some other solution.

The web console can provide some assistance - check there and see if there's more information.

Like Julien Femia likes this
Julien Femia Atlassian Team Jul 31, 2019

Hey @charu chhabra thanks for reaching out!

As Brian suggested above, can you open the web console and have a look at whether there is any error showing up in there? This might help you understand what is going on.

As I said in my message from a couple of weeks back, we're working on providing more meaningful error messages as we speak. Stay tuned!

Edit: I raised a support ticket for this. In my case it was a confirmed bug. There was a workaround provided which worked for me.

https://jira.atlassian.com/browse/JSWCLOUD-18065

We just encountered this on one of our next-gen projects. All subtasks are closed for issues in the current active sprint.

The console indicates that one issue has incomplete subtasks. However, that issue is not in the active sprint we are trying to close. It is in the next sprint. 

But after looking at the activity history of the offending issue, it appears it was initially included in the active sprint, but was then moved to the next sprint. Perhaps there is a bug with changing an issue from an active sprint to either an inactive one or to the backlog?

I tried moving the offending issue into the backlog, but the active sprint still won't close. Continues to produce the error that the issue has incomplete subtasks.

Julien Femia Atlassian Team Aug 06, 2019

Hey @Liam

thanks for reaching out, and I'm glad someone from our support team was able to provide you with a workaround. The team will be working on a proper fix soon. You can follow the progress by watching the JSWCLOUD ticket.

Cheers!

This issue doesn't seem to have got fixed yet. 

When we're trying to close the sprint, an error reading 'Something's gone wrong
Sprint cannot be completed as there are incomplete subtasks on following issues: ' 

For the subtasks being pointed to, we are unable to view the 'Sprint' field for (the subtasks).

Also, the main story has been moved out of the sprint in question here. 

Not sure how our sprint will get closed here...

Like Dávid Bortňák likes this

We are having the exact same issue.  It complains that two tasks have subtasks that are not completed, however the tasks in question are moved out of the sprint.  This is making the next-gen project really unusable. 

I have that too. This is a serious blocker to our work.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Team-managed projects

4 steps to get actual statuses on the Jira board.

Jira   is a powerful tool   that helps teams to plan, manage, and report on their work.   We love using Jira, especially for its ability to track issue progress. But how to monitor the...

1,209 views 10 14
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you