Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,277
Community Members
 
Community Events
176
Community Groups

"Failed to check login for user"when trying to loggin

I have this error when I try to log in to  a new account:
Capture.PNGr ...

3 answers

What nic said...then you take that token and enter that in as your password. I had the same issue as you and this worked for me. Sounding like loads of people having this issue right now. Token is generated at https://github.com/settings/tokens

1 vote

Yes, you'll need to create a personal access token for this account.

I'm also here for this issue but I'm struggling to apply the token to SourceTree.

If I attempt to update my account(s) within the Options there is no Authentication option for personal access token.  (see below picture)

SourceTreeAccountMenu.png

If I attempt to directly clone a new repository from the URL the prompt login window also has no option for the personal access token (see below picture) 

GitHubLoginMenu.png

Some search results went as far as to imply that the password field is where the token value is placed.  In neither scenario has this worked.  I have the latest SourceTree version installed so I'm not sure what I'm missing? 

Can you please walk through the process of taking a personal access token from GitHub and applying it within SourceTree?

The reason I answered was that I ran into exactly the same a few days before. 

As @sullycolivan answered, I entered the token as the password.  I would add that you need to make sure the username you use is identical to the username you generate the token for - I seem to remember I failed the first time because of CaPiTaLs in my username.

Like Sergio.Cardenas likes this
0 votes
Daniel Eads Atlassian Team Nov 20, 2020

Glad you all were able to come upon the answer. Given this has come up a few times, I just wanted to add the info that Github announced earlier this year they'd be disabling passwords over basic auth - and the time they'd make the hard switch (November 13, 2020) was last week. 

There are actually two ways to solve it:

  1. Generate a Personal Access Token in Github and then paste that in place of your Github password in Sourcetree as @Nic Brough -Adaptavist- and @sullycolivan mentioned
  2. Switch from Basic authentication to OAuth in the Auth type dropdown in Sourcetree for your Github account. Then click the "Connect Account" button to authorize Sourcetree (this should open your browser and just be one click in Github if you're logged in on the web already)
    image.png

Cheers,
Daniel

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events