Jira fails to start with startup parameters

I was trying to add some startup options to my Jira service on Windows for SSL email. There was a problem and when I tried to back out the changes I cannot get Jira to start now. I have now tried pasting the orginal back, hand typing all the parameters and leaving it empty. When there are no input parameters Jira will start, but not respond via the webpage. When there are ANY startup parameters I get an error like: "Windows could not start Jira on the local computer" THe log files read like:

[2013-08-07 14:47:42] [info]  ( prunsrv.c:1729) Commons Daemon procrun finished
[2013-08-07 14:55:09] [debug] ( prunsrv.c:1644) Commons Daemon procrun log initialized
[2013-08-07 14:55:09] [info]  ( prunsrv.c:1648) Commons Daemon procrun ( 64-bit) started
[2013-08-07 14:55:09] [info]  ( prunsrv.c:1561) Running 'JIRA120713110139' Service...
[2013-08-07 14:55:09] [debug] ( prunsrv.c:1345) Inside ServiceMain...
[2013-08-07 14:55:09] [info]  ( prunsrv.c:1089) Starting service...
[2013-08-07 14:55:09] [debug] ( javajni.c:195 ) Invalid RuntimeLib 'C:\Program Files\Java\jre7\bin\client\jvm.dll'
[2013-08-07 14:55:09] [debug] ( javajni.c:197 ) Using Jre JavaHome 'C:\Program Files\Java\jre7'
[2013-08-07 14:55:09] [debug] ( javajni.c:206 ) loading jvm 'C:\Program Files\Java\jre7\bin\server\jvm.dll'
[2013-08-07 14:55:09] [debug] ( javajni.c:251 ) Setting DLL search path to 'C:\Program Files\Java\jre7\bin\server'
[2013-08-07 14:55:09] [debug] ( javajni.c:251 ) Setting DLL search path to 'C:\Program Files\Java\jre7\bin'
[2013-08-07 14:55:09] [debug] ( javajni.c:660 ) Jvm Option[0] -dmail.mime.decoderparameters=true
[2013-08-07 14:55:09] [debug] ( javajni.c:660 ) Jvm Option[1] -Djava.class.path=C:\Program Files\Atlassian\JIRA\bin\bootstrap.jar;C:\Program Files\Atlassian\JIRA\bin\tomcat-juli.jar;C:\Program Files\Atlassian\JIRA\bin\tomcat-juli.jar
[2013-08-07 14:55:09] [debug] ( javajni.c:660 ) Jvm Option[2] -Xms256m
[2013-08-07 14:55:09] [debug] ( javajni.c:660 ) Jvm Option[3] -Xmx768m
[2013-08-07 14:55:09] [error] ( javajni.c:670 ) CreateJavaVM Failed
[2013-08-07 14:55:09] [error] ( javajni.c:670 ) The system could not find the environment option that was entered.
[2013-08-07 14:55:09] [debug] ( javajni.c:914 ) Java Worker thread finished : with status=2
[2013-08-07 14:55:09] [error] ( prunsrv.c:1145) Failed to start Java
[2013-08-07 14:55:09] [error] ( prunsrv.c:1504) ServiceStart returned 4
[2013-08-07 14:55:09] [info]  ( prunsrv.c:1563) Run service finished.
[2013-08-07 14:55:09] [info]  ( prunsrv.c:1729) Commons Daemon procrun finished

I get similar errors no matter what I have tried.



Error Output:

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'issueManager': FactoryBean threw exception on object creation; nested exception is java.lang.OutOfMemoryError: PermGen space
	at org.springframework.beans.factory.support.FactoryBeanRegistrySupport$1.run(FactoryBeanRegistrySupport.java:127)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.springframework.beans.factory.support.FactoryBeanRegistrySupport.doGetObjectFromFactoryBean(FactoryBeanRegistrySupport.java:116)
	at org.springframework.beans.factory.support.FactoryBeanRegistrySupport.getObjectFromFactoryBean(FactoryBeanRegistrySupport.java:91)
	at org.springframework.beans.factory.support.AbstractBeanFactory.getObjectForBeanInstance(AbstractBeanFactory.java:1288)
	at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:217)
	at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
	at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.findAutowireCandidates(DefaultListableBeanFactory.java:671)
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.resolveDependency(DefaultListableBeanFactory.java:610)
	at org.springframework.beans.factory.support.ConstructorResolver.resolveAutowiredArgument(ConstructorResolver.java:622)
	at org.springframework.beans.factory.support.ConstructorResolver.createArgumentArray(ConstructorResolver.java:584)
	... 22 more
Caused by: java.lang.OutOfMemoryError: PermGen space

2013-08-07 14:47:42 Commons Daemon procrun stderr initialized
Unrecognized option: -dmail.mime.decoderparameters=true

2013-08-07 14:55:09 Commons Daemon procrun stderr initialized
Unrecognized option: -dmail.mime.decoderparameters=true

Standard Output:

2013-08-07 14:47:29,302 localhost-startStop-1 ERROR      [internal.util.concurrent.RunnableTimedExecution] Closing runnable for context NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.jira.jira-invite-user-plugin, config=osgibundle:/META-INF/spring/*.xml) did not finish in 10000ms; consider taking a snapshot and then shutdown the VM in case the thread still hangs
2013-08-07 14:47:29,314 localhost-startStop-1 ERROR      [atlassian.plugin.manager.PluginEnabler] Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.jira.jira-invite-user-plugin
2013-08-07 14:47:30,722 localhost-startStop-1 ERROR      [atlassian.plugin.manager.DefaultPluginManager] There was an error loading the descriptor 'null' of plugin 'com.atlassian.administration.atlassian-admin-quicksearch-jira'. Disabling.
java.lang.OutOfMemoryError: PermGen space
2013-08-07 14:47:32,317 localhost-startStop-1 ERROR      [atlassian.jira.startup.LauncherContextListener] Unable to start JIRA due to Java Error.
java.lang.OutOfMemoryError: PermGen space

2013-08-07 14:47:42 Commons Daemon procrun stdout initialized

2013-08-07 14:55:09 Commons Daemon procrun stdout initialized

3 answers

0 vote
Timothy Chin Community Champion Aug 07, 2013

Anything in the JIRA log?

Out of Memory PermgenSpace --> Add this as parameter to you java command (run.bat.conf or similar in windows)


So I got Jira started, but when I went to add the rest of the startup parms that were there when I started this process I got an error when starting the windows service about how it started then stopped.

Jira Error:

Aug 08, 2013 8:42:25 AM org.apache.catalina.core.ApplicationContext log
INFO: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: loaded (conf ok)
Aug 08, 2013 8:42:27 AM org.apache.coyote.AbstractProtocol start
INFO: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: destroy called
Aug 08, 2013 8:43:25 AM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
SEVERE: The web application [] appears to have started a thread named [JonasBatch] but has failed to stop it. This is very likely to create a memory leak.
Aug 08, 2013 8:43:25 AM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
Aug 08, 2013 8:43:25 AM org.apache.coyote.AbstractProtocol stop
INFO: Stopping ProtocolHandler ["http-bio-80"]
Aug 08, 2013 8:43:25 AM org.apache.coyote.AbstractProtocol stop
INFO: Stopping ProtocolHandler ["http-bio-81"]

2013-08-08 08:44:06 Commons Daemon procrun stderr initialized
Aug 08, 2013 8:44:06 AM org.apache.catalina.startup.Bootstrap initClassLoaders
SEVERE: Class loader creation threw exception
java.io.IOException: The filename, directory name, or volume label syntax is incorrect
	at java.io.WinNTFileSystem.canonicalize0(Native Method)
	at java.io.Win32FileSystem.canonicalize(Unknown Source)
	at java.io.File.getCanonicalPath(Unknown Source)
	at java.io.File.getCanonicalFile(Unknown Source)
	at org.apache.catalina.startup.ClassLoaderFactory.createClassLoader(ClassLoaderFactory.java:171)
	at org.apache.catalina.startup.Bootstrap.createClassLoader(Bootstrap.java:150)
	at org.apache.catalina.startup.Bootstrap.initClassLoaders(Bootstrap.java:91)
	at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:227)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:426)

Common Daemons Log:

[2013-08-08 08:4
[2013-08-08 08:44:06] [debug] ( javajni.c:195 ) Invng DLL search path to 'C:\Program Files\Java\jre7\bin'
[2013-08-08 08:44:06] [debug] ( javajni.c:660 ) Jvm Option[0] -Dcatalina.base=C:\Program Files\Atlassian\JIRA -Dcatalina.home=C:\Program Files\Atlassian\JIRA -Djava.endorsed.dirs=C:\Program Files\Atlassian\JIRA\endorsed -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dmail.mime.decodeparameters=true -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Djava.io.tmpdir=C:\Program Files\Atlassian\JIRA\temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=C:\Program Files\Atlassian\JIRA\conf\logging.properties
[2013-08-08 08:44:06] [debug] ( javajni.c:660 ) Jvm Option[1] -XX:MaxPermSize=128m
[2013-08-08 08:44:06] [debug] ( javajni.c:660 ) Jvm Option[2] -Djava.class.path=C:\Program Files\Atlassian\JIRA\bin\bootstrap.jar;C:\Program Files\Atlassian\JIRA\bin\tomcat-juli.jar;C:\Program Files\Atlassian\JIRA\bin\tomcat-juli.jar
[2013-08-08 08:44:06] [debug] ( javajni.c:660 ) Jvm Option[3] -Xms256m
[2013-08-08 08:44:06] [debug] ( javajni.c:660 ) Jvm Option[4] -Xmx768m
[2013-08-08 08:44:06] [debug] ( javajni.c:844 ) argv[0] = start
[2013-08-08 08:44:06] [debug] ( javajni.c:897 ) Java Worker thread started org/apache/catalina/startup/Bootstrap:main
[2013-08-08 08:44:06] [debug] ( prunsrv.c:891 ) Start exit hook called ...

Don't try to start it with the service, but with direct BAT file.

Does it show the same errors? add all required params in the BATs, as JAVA_OPTS

OK think I tried that (I don't have an IT / software background). I got an error like "could not find or load main class Files\Attlasian\JIRA"

Charles ...

First, try to revert the changes to the initial situation when you were getting the "PermGen" error, then we will help you to add the parameter to solve this error.

The latter error (could not find main class), sounds to me like the jira installation is messed up

I had to do an uninstall - reinstall to fix it.

Thankfully my configuration was preserved...

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published Tuesday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

398 views 6 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot