JIRA Startup failed

first startup was ok (with some issues on the dashboard). after reboot and restart jira with start-jira command i got this in my browser:

The following plugins are required by JIRA, but have not been started:

  • Atlassian JIRA - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)
  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian Navigation Links Plugin (com.atlassian.plugins.atlassian-nav-links-plugin)
  • Applinks Product Plugin (com.atlassian.applinks.applinks-plugin)
  • Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)

5 answers

1 accepted

Hi, you just try the following and check once. 
  1. Shutdown JIRA
  2. Remove the following files:
    $JIRA_HOME/plugins/.bundled_plugins
    $JIRA_HOME/plugins/.osgi_plugins
    

    These are temporary files and folders and will be recreated when JIRA starts.

  3. Ensure that your JVM_MINIMUM and MAXIMUM is at least 1024
  4. Re-start JIRA

Hi, this issue can be resolved with increase memory size. Thank for advise.

I had this same issue and the steps above did not resolve it. Someone recommended that I add -Datlassian.plugins.enable.wait=300 to my catalina_opts string which helped give time to some of the slower plugins.

Thanks, it's helped!

Glad to hear it helped

This worked for me as well - thanks!.  This could / should be escalated to the docs or a FAQ.

I did the three steps at once, and used minimum memory of 1024M / max of 2048.  When I look at the process now, it is using 1.27 GB of RAM.  I did update Java to 1.8.0_66 since my last reboot, so it is possible that that could have played a factor (can't think of anything else at the moment)

It is already in the docs - the troubleshooting JIRA startup doc covers it.

Though this solution is covered by troubleshooting doc, it is fixed my exact same issue.

Same with me. Error everytime to re-start server.

0 votes

Same answer applies.

0 votes

Hi Thorsten,

 

Do you see any other errors in your logs besides the failed plugins report? Also, have you tried to apply any of the workarounds from Nic's link?

 

 

 

Error message every time to reboot is JIRA Startup Failed The following plugins are required by JIRA, but have not been started: Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets) Atlassian Navigation Links Plugin (com.atlassian.plugins.atlassian-nav-links-plugin) Atlassian JIRA - Plugins - Look And Feel Logo Upload Plugin (com.atlassian.jira.lookandfeel) Gadget Directory Plugin (com.atlassian.gadgets.directory) Note, I'm only install Service Desk v.6.3.7 or 6.3.8 and Create some issue. Error everytime to reboot. The other server v.6.2.6 is work fine. I will trie to apply with link https://confluence.atlassian.com/display/JIRAKB/Troubleshooting+JIRA+Startup+Failed+Error

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 8 hours ago in United States

Administrators Cleanup

Good morning, After a long weekend cleaning up, I am still in the cleanup mode 😊. I am curious to know: When do you feel the urgency to cleanup your Atlassian Tools? How many times do y...

15 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you