Issue with fields and screens


I've somehow hidden the 'Assignee' field from the 'create issue' screen and cannot find what the ruling parameter is to change it back. i even turned on 'allow unassigned issues' from the general configuration and still get the error when i try to add a new issue. i've gone through the help docs too and have tried different things but none have helped. can you help? thanks.

1 answer

It's either that it's missing from the screen or hidden in the Field Configuration.

Or, perhaps the user that you are testing with doesn't have 'Assign User' permission?

For the field configuration

go to the project in Administration, Projects

Click Edit to the right of your Field Congfiguration Scheme

Click the Field Configuration name associated with the issue type that you are having troubles with. If one's not listed, then click the Default field configuration name

See if Assignee is hidden. If so, un-hide it.

For the screen

You probably removed it from the Create Issue screen for that project and issue type.

I'd start at Administration, Projects and then go to the affected project name.

Then click Edit to the right of your Issue Type Screen Scheme.

Click the name of the Screen Scheme to the right of the affected Issue Type, or, if there is none listed for a particular issue type, then click the name of the default screen scheme.

Click the name of the screen to the right of Create Issue, or, if there is no Create Issue, click the name of the Default screen.

Under Add Field, highlight Assignee. Click Add

Thanks! I walked through what you suggested but still no go... I have Assignee as a field in my default screen and default screen associated with 'create new' issue, but when i actually go to create the new issue, it's not there. i know i'm doing something wrong somewhere... maybe a workflow issue?

Check your field configuration. I updated my answer

Thanks Jeff. I really appreciate your time. I've run throug the steps and still nothing. I then created a new screen scheme with only 2 fields to test it out, and Assignee gets filtered out still. Not sure if that tells you anything but it seems odd that the new scheme came through without a problem, and only that field is missing.

perhaps the user that you are testing with doesn't have 'Assign User' permission?

Thanks for the help by the way.

Got it. it was a permissions issue. The default assignee was incorrect. i still can't see the field, but at least it is no longer required...

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

285 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot