Email Notifications are not being recieved when task is assigned

Good Morning,

When I set up a task in JIRA and assign it to someone, they are not recieving the assigned notification via email. Even when I assign it to myself, I am not recieveing the task.

Can receive shared task via email. Can someone explain why. I do have the notification scheme set up for all users to see or receive all alerts.

Thank you

3 answers

1 accepted

3 votes

Check your profile - do you have "email me on my own changes" turned off?

You mention specifically the "assign" process - could you tell us how you are assigning here? I mean by changing assignee during a transition, via an edit, via the "assign" link, or in greenhopper?

Create issue --> Assignee drop down box --> choose assignee. Then close ticket. Sometimes I assign users during transition or via edit. Either way it should work right? I am Jira admin and even my account is not getting task assignments.

Ok, that's the "create" transition, not the assignee. So, the next questions:

Does your "create" transition fire the "issue created" event?

Who does your notification scheme say to mail on "issue created"?

Did you check your "email me" settings?

(Forget the admin thing, it doesn't do anything different from any other group/role, unless you specifically configure it to do so)

Issue Updated (System)
Issue Assigned (System)
Issue Resolved (System)
Issue Closed (System)

What's the difference between editing the Assignee field and pressing the Assign button? Do they both throw the Issue Assigned event? The button seems to add the new Assignee to the Watchers list.

There's four ways to change the assignee: - Assign (to me) button(s) - changes just the assignee, fires an "assign issue" event - Click the field in the view to edit it - as above - Edit the issue - because other fields are changing, this fires an "issue updated" event - Change during a transition - needs to fire the transition event

Hi Matthew,

Could you please check whether the mail server is properly configured?Also, does the issue create step has proper event configured in the post function.(Please check your workflow transition to see about post functions)

Thanks,

Anshul

I have figured it out with the help of all of you guys. I had to change who the emails were going to (project roles --> group accounts [admin, dev, user). Once I changed it. I was recieving emails.

Thank you all

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted 6 hours ago in Off-topic

Miscellaneous Monday - CreatatronV3

You may remember, not so long ago, that together we invented the most evil of machines: The Destructo5000!  The effects of missing Durian rippled over nations. Complete chaos as goat chee...

55 views 4 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you