Hello!
The hostname (ldap.example.com) that we used, when configuring JIRA's user-directory, resolves to several IP-addresses -- we run several replicas for load-sharing and redundancy.
Today we had a problem with one of the replicas and JIRA began having intermittent problems of its own with logins. The error, showing under "Technical Details" of JIRA's apologetic error-page was "Connection Refused".
This surprised me, because I expected JIRA to go through all IPs returned by gethostbyname() -- not give up after failing to connect to the first address on the list.
Is there a way to configure the directory in JIRA to make the LDAP connectivity reliably survive an outage of one of the LDAP-servers? A downed LDAP-server may still introduce a delay (although JIRA could try connecting to all IPs in parallel), but, as long as one of the LDAP-servers remains up and reachable, the user should not get an error...
Perhaps, I can somehow list multiple ldap.url-fields for the same directory? Thanks!