It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

ComponentAccessor in jira always returning "null" while accessing a component. How exactly do we use this to get an object of a class?

hi,

I am using ComponentAccessor to get an object of a component as ComponentManager methods appear all to be deprecated. So far i have tried the following code and it always returns null.

1. ComponentAccessor.getComponent(EpicLinkManagerImpl.class)

2. ComponentAccessor.getComponentofType(EpicLinkManagerImpl.class)

The EpicLinkManagerImpl.class belongs to the jira greenhopper plugin and i am tring to access this in my own custom plugin.

how can i achieve this? is there anything im doing wrong? or is there any other alternative?

2 answers

It's not a component, or not a public component. You could try using the latest version of script runner and seeing Working With JIRA Agile.

hi jamie,

thanks for replying. Can you please post the corresponding java code snippet for your answer?

hi jamie, thanks for your answer.

I am facing problem regarding greenHopperCacheManager and applicationContext in the variation of this code in java. Can someone please share the corresponding code snippet in java?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Align

Best Practices in Jira Align

Hello Jira Align customers! In order to better serve you on your journey with Jira Align, the Community team has worked with the Jira Align team to curate the content in this collection to better s...

45 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you