• Community
  • Questions
  • Cannot create application link between Jira and Confluence (HTTPS/SSL)

Cannot create application link between Jira and Confluence (HTTPS/SSL)

I'm new to Atlassian products. After a fresh server install of Jira 7.3.1, Confluence 6.1.4 and Bitbucket 5.0.1 on Ubuntu 16.04 I changed the access method for all three products to HTTPS/SSL and created bidirectional application links from Bitbucket to Jira and from Bitbucket to Confluence. Working well.
The existing application link between Jira and Confluence was broken due to the switch from HTTP to HTTPS/SSL. So I deleted this broken application link.
But I had no success creating this application link newly:
On the Jira form "Application Links" (<jira>/plugins/servlet/applinks/listApplicationLinks) I entered the Confluence Base URL.
The "Link applications" dialog was shown, where I checked "The servers have the same set of users and usernames".
The "Administrator Access" dialog was shown.
After logging in again the Jira form "Application Links" was shown without a newly created application link. There was no error message and no switch to Confluence to create the reciprocal application link.
In <jira>/logs/catalina.out I found the following entry:
<timestamp> JIRA-EventThread-73 WARN <user> 1330x2098x2 iucv0o /rest/applinks/3.0/manifest.json [c.a.a.internal.capabilities.DefaultRemoteCapabilitiesService] Exception trying to get Applink for manifest with ID 065086d1-5d0c-3faf-a14b-520c62269424

(One note: I'm using two self signed certificates: one for Jira and Confluence and one for Bitbucket.)

1 answer

0 vote

Hi Harmut,

I would take a look at Application link not working due to "ManifestNotFoundException." One quick way you can get some more information is through curl. Verify the connection can be established from the target to the source server on the command-line using curl - you'll have to install this in Windows from curl.haxx.se - as per the below example:

curl -H "Accept: application/json" http://yourBaseURL:8080/rest/applinks/1.0/manifest -v

Replace yourBaseURL with the hostname of the target.

Hopefully that in conjunction with the information in Application link not working due to "ManifestNotFoundException" will give you more information to go on that you can use to resolve this. If not, post the results of the curl command



Hi Branden,

Thank you for your reply!

curl didn't deliver an error message, but a valid JSON expression.

I tried to post the curl result here, but I got the following:


Your reply was not accepted. Please check for inappropriate language or spam.

Kind Regards,



Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

153 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot