Cannot access JIRA after installing it

After installing JIRA and trying to get to the configuration (Linux version) I can see that java process is using 90% CPU and Disk usage is going up too. When I try to access the page, it takes a lot of time, and finally times out. I know it's not a 404 since I get the page title, but I get a blank page.

Is this a normal behaviour, is the first launch usually taking a lot of resource? I'm suspecting the server to be initializing, but timing out for some reason.

I'm using Ubuntu 11.10.

When I start the service I get:

To run JIRA in the foreground, start the server with start-jira.sh -fg

executing using dedicated user: jira

.....

.... .NMMMD. ...

.8MMM. $MMN,..~MMMO.

.?MMM. .MMM?.

OMMMMZ. .,NMMMN~

.IMMMMMM. .NMMMN. .MMMMMN,

,MMMMMM$..3MD..ZMMMMMM.

=NMMMMMM,. .,MMMMMMD.

.MMMMMMMM8MMMMMMM,

.ONMMMMMMMMMMZ.

,NMMMMMMM8.

.:,.$MMMMMMM

.IMMMM..NMMMMMD.

.8MMMMM: :NMMMMN.

.MMMMMM. .MMMMM~.

.MMMMMN .MMMMM?.

Atlassian JIRA

Version : 5.1.4

Detecting JVM PermGen support...

PermGen switch is supported. Setting to 256m

If you encounter issues starting or stopping JIRA, please see the Troubleshooting guide at http://confluence.atlassian.com/display/JIRA/Installation+Troubleshooting+Guide

Server startup logs are located in /opt/atlassian/jira/logs/catalina.out

Using CATALINA_BASE: /opt/atlassian/jira

Using CATALINA_HOME: /opt/atlassian/jira

Using CATALINA_TMPDIR: /opt/atlassian/jira/temp

Using JRE_HOME: /opt/atlassian/jira/jre/

Using CLASSPATH: /opt/atlassian/jira/bin/bootstrap.jar

Using CATALINA_PID: /opt/atlassian/jira/work/catalina.pid

Existing PID file found during start.

Removing/clearing stale PID file.

Also, if it isn't working, I'd like to know if there's a written procedure for uninstalling JIRA correctly. (I've ran the .bin file and don't know what has been added and where).

Thanks

2 answers

1 accepted

1 vote

Hello Joel,

I believe that this problem is the amount of physical RAM of your server, since you have only 512MB and it is not enough to proper run JIRA. Additionally, I could see that you have only 128MB allocated to the JVM, on your Java settings.

Thus, please increase your physical RAM to at least 2GB and increase the JVM memory, as per the instructions on the following article:

For more information about the hardware recommendations for JIRA, please refer to the following document:

Cheers!

1 vote

Joel,

Do you have multiple JIRA processes running? What output do you get if you type the following:

ps aux|grep jira

If there are multiple JIRA processes running, the behavior you mentioned can sometimes occur. Be sure there are no processes running when you run the start up command.

You can also tail the jira log file on startup if you want to see what's happening.

bin/startup.sh ; tail -f /opt/atlassian/jira/logs/atlassian-jira.log (or whatever the path to your log files is)

Also check the jira log file under /opt/atlassian/jira/logs/atlassian-jira.log for errors; that may help you pinpoint any startup errors. Or you can paste them here and get help.

You should be able to fix the problem without uninstalling.

I tried doing what you told me :
  1. no there's only 1 jira process
  2. well I tried what you suggested, and couldn't find the atlassian-jira.log, so I went in the catalina log. Here's what there is at some point, can you just confirm that this is a normal behaviour?

Here's the pastebin link : http://pastebin.com/DN84ZryS

As you can see there seems to be many plugins that can't be loaded...

Can you post more of the log? What are your memory settings? With high CPU and plugins not loading it could be out of memory.

Sure here's the complete catalina.out log : http://leetzone.ca/catalina.log

My memory setting is actually of a VPS with 512mb of RAM and a share of 4 Xeons.

You definitely need to reduce the memory setting in JIRA's setenv.sh or wherever this has been set.

It says: Maximum Allowable Memory : 742MB

Meaning you've allocated 742MB to it when you've got 512MB including OS overhead and other things. Try that. However, it isn't recommended to run JIRA on a 512mb VPS.

Can you point me out where this file is? At least I could try it, I don't have any other choice than either reduce memory, or not using Jira at all :P

edit: nvm found it

Could you tell me why there's an IO exception at the startup (after changing the min/max memory)

http://leetzone.ca/catalina.log

2012-09-13 08:39:34,280 main ERROR      [atlassian.jira.plugin.PluginPath$JiraHomeAdapter] Unable to delete file: /var/atlassian/application-data/jira/plugins/.osgi-plugins/felix/felix-cache/bundle44/bundle.id  exists:true  canRead:true  canWrite:false  isDirectory:false
2012-09-13 08:39:34,281 main FATAL      [atlassian.jira.upgrade.PluginSystemLauncher] A fatal error occured during initialisation. JIRA has been locked.
com.atlassian.plugin.osgi.container.OsgiContainerException: Unable to clean the cache directory: /var/atlassian/application-data/jira/plugins/.osgi-plugins/felix
....

It looks like you've also got permissions problems with your directories. Please ensure the user running JIRA has enough read/write rights. It currently doesn't have the right to delete a file.

Having said that, might be good to clear the felix cache in this case by deleting everything inside the felix-cache folder.

All right, I fixed the permissions and cleared the cache. Now I think this is the farthest I've got.

I also updated the log: http://leetzone.ca/catalina.log

It seems it's timing out to load the plugins!

You reduced the memory too much :). Try 384mb or something. I'm not sure what else you have running there, but...

Well I've trying giving it more memory, but it's still the same. I think my VPS just doesn't have enough memory. Thanks for your help!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

384 views 4 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you