A fatal error has occurred

HI,

After the installation, got the fatal error while accessing the stash.

A fatal error has occurred

The following problems occurred which prevents Atlassian Stash from starting correctly:

  • Required plugin com.atlassian.templaterenderer.api has failed to start
  • Required plugin com.atlassian.stash.stash-jira-integration has failed to start
  • Required plugin com.atlassian.crowd.embedded.admin has failed to start
  • Required plugin com.atlassian.plugins.atlassian-nav-links-plugin has failed to start
  • Required plugin com.atlassian.templaterenderer.atlassian-template-renderer-velocity1.6-plugin has failed to start
  • Required plugin com.atlassian.oauth.consumer.sal has failed to start
  • Required plugin com.atlassian.applinks.applinks-plugin has failed to start
  • Required plugin com.atlassian.oauth.consumer has failed to start
  • Required plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin has failed to start
  • Required plugin com.atlassian.stash.stash-stp-integration has failed to start
  • Required plugin com.atlassian.oauth.serviceprovider.sal has failed to start
  • Required plugin com.atlassian.oauth.serviceprovider has failed to start
  • Required plugin com.atlassian.stash.stash-velocity-helper has failed to start
  • Required plugin com.atlassian.plugins.rest.atlassian-rest-module has failed to start

tried removing the plugins .bundled-plugins and .osgi-cache that didnt fix theissue please help with this, here is my Stash URL

https://ec2-54-164-23-13.compute-1.amazonaws.com:443

Thanks

3 answers

This widget could not be displayed.

https://confluence.atlassian.com/display/STASHKB/Stash+failed+to+Start+due+to+Required+plugin+failed+to+start

It is possible you use old version of stash and latest version of java. Please think about setting up java engine of older version than 8 or upgrade stash to latest.

This widget could not be displayed.

Thanks for the immediate response, I am using the latest version of stash (stash-3.0.7) and

the java version "1.7.0_65"
OpenJDK Runtime Environment (rhel-2.5.1.2.el6_5-x86_64 u65-b17)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

Git version: 1.7.12.4 , perl version: v5.10.1

I was able to access the setup before, Got this plugin error after the SSL configuration. here are logs please check it and help with this issue.

======================

2014-08-13 09:25:50,588 WARN [Timer-1] o.s.o.e.i.d.s.DependencyWaiterApplicationContextExecutor Timeout occurred before finding service dependencies for [NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.upm.atlassian-universal-plugin-manager-plugin, config=osgibundle:/META-INF/spring/*.xml)]
2014-08-13 09:25:50,589 ERROR [Timer-1] o.s.o.e.i.d.s.DependencyWaiterApplicationContextExecutor Unable to create application context for [com.atlassian.upm.atlassian-universal-plugin-manager-plugin], unsatisfied dependencies: Dependency on [(objectClass=com.atlassian.sal.api.net.RequestFactory)] (from bean [&requestFactory]), Dependency on [(objectClass=com.atlassian.templaterenderer.TemplateRenderer)] (from bean [&templateRenderer])
org.springframework.context.ApplicationContextException: Application context initialization for 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' has timed out
at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor.timeout(DependencyWaiterApplicationContextExecutor.java:454) [spring-osgi-extender-1.2.1.jar:1.2.1]
at java.util.TimerThread.mainLoop(Timer.java:555) [na:1.7.0_65]
at java.util.TimerThread.run(Timer.java:505) [na:1.7.0_65]
... 2 frames trimmed
2014-08-13 09:25:50,590 ERROR [Timer-1] c.a.plugin.osgi.factory.OsgiPlugin Plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' never resolved service '&requestFactory' with filter '(objectClass=com.atlassian.sal.api.net.RequestFactory)'
2014-08-13 09:25:50,590 ERROR [Timer-1] c.a.plugin.osgi.factory.OsgiPlugin Plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' never resolved service '&templateRenderer' with filter '(objectClass=com.atlassian.templaterenderer.TemplateRenderer)'
2014-08-13 09:25:50,594 ERROR [Timer-1] c.a.plugin.osgi.factory.OsgiPlugin Unable to start the plugin container for plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
org.springframework.context.ApplicationContextException: Application context initialization for 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' has timed out
at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor.timeout(DependencyWaiterApplicationContextExecutor.java:454) ~[na:na]
at java.util.TimerThread.mainLoop(Timer.java:555) ~[na:1.7.0_65]
at java.util.TimerThread.run(Timer.java:505) ~[na:1.7.0_65]
... 2 frames trimmed
2014-08-13 09:25:50,594 ERROR [Timer-1] o.s.o.e.i.a.ContextLoaderListener Application context refresh failed (NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.upm.atlassian-universal-plugin-manager-plugin, config=osgibundle:/META-INF/spring/*.xml))
org.springframework.context.ApplicationContextException: Application context initialization for 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' has timed out
at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor.timeout(DependencyWaiterApplicationContextExecutor.java:454) [spring-osgi-extender-1.2.1.jar:1.2.1]
at java.util.TimerThread.mainLoop(Timer.java:555) [na:1.7.0_65]
at java.util.TimerThread.run(Timer.java:505) [na:1.7.0_65]
... 2 frames trimmed
2014-08-13 09:25:51,505 ERROR [localhost-startStop-1] c.a.plugin.osgi.factory.OsgiPlugin Plugin 'com.atlassian.stash.stash-velocity-helper' never resolved service '&templateRenderer' with filter '(objectClass=com.atlassian.templaterenderer.TemplateRenderer)'
2014-08-13 09:25:51,557 ERROR [localhost-startStop-1] c.a.plugin.manager.PluginEnabler Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.upm.atlassian-universal-plugin-manager-plugin,com.atlassian.stash.stash-velocity-helper
2014-08-13 09:25:56,715 INFO [localhost-startStop-1] c.a.s.internal.scm.PluginScmService Stash is using /usr/bin/git version 1.7.12.4
======================

Thanks

This widget could not be displayed.

Hi,

Still I am facing this fatal error, please check it and help me to solve this issue.

Thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

73 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you