Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira plugin Java Spring Configuration fail to resolve dependency


I've started a plugin development from scratch and used atlas-create-jira-plugin command via the Atlassian sdk. I've chosen Spring Java Configuration as a main way to import components, following this documentation.

The atlas-mvn package command worked and I was able to upload the app in jira instance and could develop the plugin continuously until yesterday.

Today the SpingConfig in which the bean configuration is stored, failed to import the static helper service "importOsgiService" by which I used to bring in and instantiate the beans. 

import static com.atlassian.plugins.osgi.javaconfig.OsgiServices.*;
public TemplateRenderer templateRenderer(){
return importOsgiService(TemplateRenderer.class);

To solve this, I tried to run atlas-mvn clean install and atlas-mvn clean package hoping it would resolve the dependency again.

Since then, maven is unable to resolve the dependency for com.atlassian.plugin:atlassian-plugins-osgi-javaconfg. 

The error in IntelliJ: 

No versions available for com.atlassian.plugins:atlassian-plugins-osgi-javaconfig:pom:[0.2.0,0.3.1) within specified range.

Any help or suggestion is appreciated. Just want to mention that I am new into the Spring world and know just the basics. 

Down below is the configuration in my pom.xml:


<?xml version="1.0" encoding="UTF-8"?>

<project xmlns=""


<name>Example Company SE</name>

<description>Provides functionality to view group members in Users and Roles page in jira Administration. </description>




<!-- -->


<version>2.5</version> <!-- fix for JIRA 7.x in order to bind to Servlet API 3.0 -->

<!-- OSGi Java Config dependencies -->






<!-- See here for an explanation of default instructions: -->
<!-- -->

<!-- Add package to export here -->

<!-- Add package import here -->

<!-- Ensure plugin is spring powered -->

<!-- This property ensures consistency between the key in atlassian-plugin.xml and the OSGi bundle's key. -->



1 answer

Found the answer on a post on stackoverflow. 

The dependency does not come directly from maven public repository, but instead of an atlassian repository. 

adding this to my pom.xml solved the issue: 

<name>Atlassian Public</name>

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in New to Jira

Check out the ✨NEW✨ Group for Jira Cloud Admins

Hello Community members!  Wanted to give you the heads up about a NEW Community Group for Jira Cloud Admins.  This is a group where you can ask questions, access resources, and rub elb...

81 views 0 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you