It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

web ui fails to render at issue view page

At issue view page, see errors.

I tried to restart Jira container after google. no luck.

Error rendering 'com.atlassian.jira.jira-view-issue-plugin:details-module'. Please contact your Jira administrators.

Error rendering 'com.atlassian.jira.jira-view-issue-plugin:peoplemodule'. Please contact your Jira administrators.

1 answer

0 votes
Fadoua Community Leader Jan 14, 2020

@lumin_lumin 

Since you mentioned container I am assuming you are using docker.

Did you try to list your containers?

What are you seeing?

There will be couple commands to run in order to make sure that your container is still there, and wasn't deleted. Is your license still valid?

Best,

Fadoua

Fadoua, thanks.

how can I upload logs to Jira for further analysis?

The docker containers are running fine. The Jira has valid license and the UI pages (admin, issue creation) are responding to requests .  see the screen inserted for the error.

 

 

Screenshot_2020-01-15 [EW-19] Customer Questionnaire - Jira.png

 

 

Screenshot_2020-01-14 [My open issues] Issue Navigator - Jira.png

Fadoua Community Leader Jan 14, 2020

Unfortunately you can only copy/paste the logs @lumin_lumin .

Did you check if all macros under system installed plugins are enabled?

Faodoua:

  are there Jira docs on how to check Macros? here is the screenshot of the details module config. it can not render but shows enabled in the config.

Fadoua:

 

https://confluence.atlassian.com/jirakb/error-occurs-on-detail-module-under-issue-view-page-300811192.html

I tried that one as well. the dir is /root and is empty.  I restarted the docker container and no luck. should I try to restart Jira app, not the container? if so, how do I restart Jira in docker?

 

$JIRA_INSTALL/work
Fadoua Community Leader Jan 14, 2020

docker restart jira

Also are you Jira Admin? If yes you should be able to see the cog at the top right corner on the application.

Click on it and then try to go to manage apps

yes, I am Jira Admin. pls see the "manage apps" page.

where do I check the Macro status?

I tried the docker restart and it did not solve the problem.

Fadoua Community Leader Jan 14, 2020

@lumin_lumin  you didn't attach the screenshot

I tried to paste the log entries here but can not. does this forum limit the size of post?

Fadoua Community Leader Jan 14, 2020

@lumin_lumin Please be really careful when you are checking the system plugins.

Click on the arrow pointing to the right by the plugin name it will show you how many macros you have in total if it says for example 20 of 23 then you know that 3 of them are disabled.

I checked every add-on with "issue" in the name and do not find any macro which are disabled.

what else can we check?

Screenshot_2020-01-15 Manage apps - Jira(2).png

Fadoua Community Leader Jan 14, 2020

Ok let me ask you this question: did this behaviour just start? Was the information displaying properly before @lumin_lumin ?

I am not sure. I set up this server just a few days ago.

I noticed the issue after I imported a project into the new server.

btw, how can I post log entries here? it does not allow me to post.

Jira error logs say "projectRole is null" when the pages with errors are loaded.

however, the project has its roles and members defined.

please advise how to proceed.

2020-01-14 22:09:48,208 http-nio-8080-exec-7 ERROR luminadmin 1329x4244x1 gboclq 10.0.20.23 /browse/EW-19 [c.a.j.web.component.ModuleWebComponentImpl] An exception occured while rendering the web panel: com.atlassian.jira.jira-view-issue-plugin:datesmodule (null)
java.lang.IllegalArgumentException: Cannot determine field screen for operation 'admin.issue.operations.view'.
at com.atlassian.jira.issue.fields.screen.FieldScreenSchemeImpl.getFieldScreen(FieldScreenSchemeImpl.java:123)
at com.atlassian.jira.issue.fields.screen.StandardFieldScreenRendererFactory.createFieldScreenRenderer(StandardFieldScreenRendererFactory.java:48)
at com.atlassian.jira.issue.fields.screen.FieldScreenRendererFactoryImpl.getFieldScreenRenderer(FieldScreenRendererFactoryImpl.java:45)
at sun.reflect.GeneratedMethodAccessor556.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.atlassian.plugin.util.ContextClassLoaderSettingInvocationHandler.invoke(ContextClassLoaderSettingInvocationHandler.java:26)
at com.sun.proxy.$Proxy350.getFieldScreenRenderer(Unknown Source)
... 2 filtered
at java.lang.reflect.Method.invoke(Unknown Source)
at com.atlassian.plugin.osgi.bridge.external.HostComponentFactoryBean$DynamicServiceInvocationHandler.invoke(HostComponentFactoryBean.java:131)
at com.sun.proxy.$Proxy350.getFieldScreenRenderer(Unknown Source)
at com.atlassian.jira.plugin.viewissue.DateBlockContextProvider.getDateCustomFieldModels(DateBlockContextProvider.java:105)
at com.atlassian.jira.plugin.viewissue.DateBlockContextProvider.getContextMap(DateBlockContextProvider.java:88)
at com.atlassian.jira.plugin.webfragment.CacheableContextProviderDecorator.initContextMap(CacheableContextProviderDecorator.java:63)
at com.atlassian.jira.plugin.webfragment.CacheableContextProviderDecorator.getContextMap(CacheableContextProviderDecorator.java:41)
at com.atlassian.plugin.web.descriptors.DefaultWebPanelModuleDescriptor$ContextAwareWebPanel.getHtml(DefaultWebPanelModuleDescriptor.java:134)
at com.atlassian.jira.web.component.ModuleWebComponentImpl.renderModule(ModuleWebComponentImpl.java:81)
at com.atlassian.jira.web.component.ModuleWebComponentImpl.access$000(ModuleWebComponentImpl.java:30)
at com.atlassian.jira.web.component.ModuleWebComponentImpl$1.run(ModuleWebComponentImpl.java:67)
at com.atlassian.ozymandias.SafePluginPointAccess.runnable(SafePluginPointAccess.java:404)
at com.atlassian.jira.web.component.ModuleWebComponentImpl.renderModuleAndLetNoThrowablesEscape(ModuleWebComponentImpl.java:63)
at com.atlassian.jira.web.component.ModuleWebComponentImpl.renderModule(ModuleWebComponentImpl.java:53)
... 2 filtered

Fadoua Community Leader Jan 15, 2020

ok let me see what I will be able to find in the logs @lumin_lumin 

Fadoua Community Leader Jan 15, 2020

@lumin_lumin  I missed one of your answers yesterday

You said you imported a project:

  • What Jira version was your project created in?
  • Before importing the project did you follow Atlassian documentation? Made sure that you have everything the same between source and target instance otherwise you will see errors and this one you are getting could be triggered because of some missing features.
  • Check the following link:

https://confluence.atlassian.com/adminjiraserver072/importing-projects-into-the-target-instance-933088195.html

 

Best,

Fadoua

I will do the project migration again to have another test.

The current migrated project has some development going on.

how can I keep the current migrated project while doing another migration? I ask so as I worry the new migration may overwrite the current project as it happens on the same project in the source.

 

thank you

Like Fadoua likes this
Fadoua Community Leader Jan 15, 2020

Refrain from any changes at the moment as they will create a mess in your instance.

Is there a way for you to create another Jira instance with docker? So that you can try importing your project properly following Atlassian guidelines.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you