(some) Users get a HTTP 500 Error after logging in after updating Jira to 10.x

SK3000 January 6, 2025

Hello, 

we have a massive problem after updating Jira to the LTS Version 10.3

Some users get an HTTP 500 Error: "Sorry, we had some technical problems during your last operation."

 

Cause

Referer URL: Unknown

com.atlassian.jira.web.pagebuilder.PageBuildingException: javax.servlet.ServletException: com.google.common.util.concurrent.ExecutionError: java.lang.NoClassDefFoundError: com/atlassian/plugin/web/api/model/WebFragmentBuilder

2025-01-06 11_02_28-skoenning-Oops - an error has occurred.png

 

Chrome Debugging in Developer Mode shows the following Error:

 

ERR_INCOMPLETE_CHUNKED_ENCODING

2025-01-06 10_58_03-skoenning-Browse projects - Lichtgitter JIRA.png

What can be the issue for this?

Some users can login and work normally with Jira and Jira Service Management.


Thanks a lot for your help!

 

 

2 answers

2 accepted

3 votes
Answer accepted
SK3000 January 6, 2025

Hello Jeroen,

thanks a lot for the fast answer!

We did the steps, but without success.

But after that we checked the plugins and discovered an old plugin "Easy Tracking" which is not supported in version 10.x and only 9.x.

After disabling it, everything worked again!

Thanks

Stephan

3 votes
Answer accepted
Jeroen Poismans
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
January 6, 2025

Hi and welcome to the community!

It seems that there is an old version of a package interfering with the newer Jira version dependencies. Have you tried clearing the Jira caches?

Here is how:
https://confluence.atlassian.com/jirakb/how-to-clear-jira-data-center-server-plugin-cache-1157468195.html

CAUTION: This will require server access and shutdown / restart of your application, so only proceed if you know what you are doing.

Jeroen

SK3000 January 6, 2025

Thanks! i posted the solution in a new comment :-)

Suggest an answer

Log in or Sign up to answer