• Community
  • Products
  • Jira
  • Questions
  • "You don't have access to view all related commits. Please contact your administrator." message while trying to view commit

"You don't have access to view all related commits. Please contact your administrator." message while trying to view commit

Hello,

After upgrading to JIRA 6.2 I tried to use developer panel. I see that there was commit but after I click on the link, windows appear with message "You don't have access to view all related commits. Please contact your administrator.". I'm administrator on both Fisheye and JIRA so permission shouldn't be the problem. I see in Source tab what commits without any problem. I tried viewing log but I didn't see any logs about problems with permissions.

26 answers

1 accepted

Lukasz,

Disabling Crowd SSO in Fisheye seems to solve the problem for me. But it's only workaround. Will your fix to AJP authentication also fix problem with Crowd SSO ?

Lukasz Pater Atlassian Team Mar 30, 2014

Hi Hubert, thanks for confirming.

I've managed to verify that the problem affects Crowd SSO configurations as well, and that the fix for FISH-656 will also fix those.

The fix should be included in the FishEye/Crucible 3.3.3 release.

Lukasz Pater Atlassian Team Mar 30, 2014

Tracked as https://jira.atlassian.com/browse/FE-5126in FishEye/Crucible.

The fix will be included in the upcoming 3.3.3 and 3.4.0 releases.

First: Thanks for the rapid answers!

Unfortunately the impersonation setting is switched off in the app link.

Starting from scratch:

- I create the application link and check if 2LO is activated on both sides, but impersonation is off.

- After that i can see the dev-panel

- I click on "3 commits" getting this screen:

- I click on the displayed link getting this screen:

- I click on "Grant Access" getting this:

Tried almost everything here....

Thanks in advance!

I have exactly the same situation.

Here is configuration of fisheye app link.

We got the same problem after upgrading from JIRA 6.1 to JIRA 6.3.7 (also upgraded FishEye to 3.5.4 around the same time, not sure what we were on before). We were getting the following error message in the FishEye logs:

2014-11-10 10:28:20,643 WARN [qtp2071597764-47985 ] com.atlassian.security.auth.trustedapps.filter.TrustedApplicationFilterAuthenticator TrustedApplicationFilterAuthenticator-authenticate - Failed to login trusted application: jira:13199862 due to: com.atlassian.security.auth.trustedapps.InvalidCertificateException: Request not allowed to access URL: /rest/dev-status/1.0/details/repositories
2014-11-10 10:28:20,644 ERROR [qtp2071597764-47985 ] com.atlassian.fisheye.trustedapplications.FisheyeAuthenticationListener FisheyeAuthenticationListener-authenticationError - Error handling trusted applications authentication attempt:BAD_URL; Request not allowed to access URL: {0}; ["/rest/dev-status/1.0/details/repositories"] remote host:http://fisheye:8060/rest/dev-status/1.0/details/repositories remote port:51535

Therefore I edited the JIRA Application Link in FishEye and added the following line to Incoming Authentication: URL Patterns

/rest/dev-status/1.0/details/repositories

This fixed the problem.

Same Problem here. I enabled the two legged auth. running Jira 6.2 and Fisheye 3.3.1. source and builds tabs contain the information but the dev-panel gives the error message above. The "View Development Tools" Permission ist set. Just upgraded to Jira 6.2.1, still not working.

0 vote

May I know if the 2LOi enabled? Needs to be disabled.

I do not exactly know where to look if 2LOi is enabled (or what you mean with 2LOi). Do you mean the 2-legged OAuth? This is enabled and has to be, if I understand it right.

Is it more a setting within a plugin?

0 vote

See https://confluence.atlassian.com/display/JIRA/Integrating+JIRA+with+Code+Development+Tools#IntegratingJIRAwithCodeDevelopmentTools-ConnectingStash,FishEye/CrucibleorBambootoJIRAthe (i) in 2LOi means "Allow user impersonation through 2-Legged OAuth". Please ensure this impersonation is switched off.

Hope that helps,
Piotr

0 vote

Allow user impersonation through 2-Legged OAuth

Is what I meant by 2LOi. :)

Hey,

2LOi is switched off in my app link. This is configuration I made to connect to fisheye.

I hope this will help to solve our problem.

0 vote
Lukasz Pater Atlassian Team Mar 18, 2014

Hi TENSQ, Hubert,

while the content of the developer panel (X commits, Y branches, etc.) on the issue screen is retrieved using 2LO (and doesn't take into account the user you're currently logged in as), the content of the details dialog (the one that shows up when you click on the 'commits' link for example), is retrieved using 3LO and only shows content that the your user in the remote app has permission to see. If the two don't match you'll see the 'don't have access' message you included above.

Some things to check:

  • make sure that the 3LO token you have in JIRA corresponds to the right user in FishEye (the easiest way to do it is to go (in JIRA) to Profile/Tools/View OAuth access tokens and revoke the FishEye token to recreate it, and make sure you're logged in as the right user in FishEye and JIRA before recreating
  • it is possible for a user to be a FishEye administrator, but to not have access to a specific repository. Please check the repository permissions (in Admin/Repositories/Permissions), and make sure the group your user is a member of is checked in the 'Can read' column. Also check if you can open the repository and search for related commits in FishEye directly.

Hope this helps.

Hi Lukasz,

Are you sure that I need to check profile in JIRA, not in Fisheye ? Because in JIRA I have information that none applications are authorised, but in Fisheye I see that JIRA is using my account to access Fisheye data. I revoked access and recreated it. I'm using Crowd repository in JIRA and Fisheye and I configured SSO auth between Atlassian products.

To all repositoriess "All logged-in users" permission is set.

Lukasz Pater Atlassian Team Mar 18, 2014

You're right - the right token to check would be in FishEye.

Have you checked if you can search for the commits as the user in FishEye (using the issuekey as the search query)?

You might also check if the 'Issue Dev Summary plugin', and all it's modules are enabled.

Also try hitting the '/rest/dev-status/1.0/details/repositories?globalId=ISSUEKEY-XXX' REST endpoint as the user, and see if it returns expected commit data.

If the problem still persists, do raise a support ticket.

Hi Lukasz,

I've done everything You wrote here - I can search for the commits using the issuekey, issue dev summery plugin is enables and so are all it's modules, hitting the '/rest/dev-status/1.0/details/repositories?globalId=ISSUEKEY-XXX' returns some data.

I raised support ticket.

Thank for your help.

Did you ever get a resolution on this? I'm having the same issue.

Same problem here.

No, I didn't get solution yet. I raised the support ticket and I'm currently waiting for Atlassian to replay.

Hi guys,

Till now I didn't get any solution to our problem, but when I'll I'm gonna share it with you.

I turned on debug logging in Fisheye and I'm seeing this error:

2014-03-27 11:32:13,046 DEBUG [qtp2075111623-44833 ] fisheye DefaultCommitDetailsService$DocInfoToRepositoryDetailsConverter-apply - Skipping repository 'medio' because it is not running

This is the repo Jira is trying to access, and I have verified that this repo is running.

Same problem for us.

Same problem for us.

0 vote

@Hubert

Not sure whats the progress here, but you need to disable Trusted Application.

Disabling Trusted Application seemed to break smart commits for us.

0 vote
Lukasz Pater Atlassian Team Mar 30, 2014

Jean, TENSQ, Hubert,

are any of you using AJP or Crowd with Single Sign-On authentication in FishEye? We've just confirmed a bug with that configuration, please see: https://ecosystem.atlassian.net/browse/FISH-656. Potentially it also might affects setups with Crowd SSO enabled.

Turning off SSO worked for me.

We are using Crowd with Single Sign-On authentication in FishEye. Crowd is using HTTPS (apache) > HTTP (tomcat) proxing and fisheye is also using HTTPS (apache) > http (fisheye embedded jetty container) setup. Same applies to our Jira installation (HTTPS (apache) > HTTP (tomcat)), no AJP connector is used.

0 vote
Lukasz Pater Atlassian Team Apr 03, 2014

FishEye/Crucible 3.3.3 was released today, which should resolve this issue for AJP and SSO configurations.

You can download it at https://www.atlassian.com/software/fisheye/download

Just installed it (3.3.3) and its working perfect, thanks for that! For Bamboo though, I get the same message: "You don't have access to view all related builds. Please contact your administrator."

Help, anyone?

Hi all.
We've just updated our Jira to v.6.2.6 and FishEye to v.3.4.4
Issue is still present:

You don't have access to view all related reviews. Please contact your administrator.

Does anyone have any suggestions?

0 vote
Daniel Rohan Atlassian Team Jun 09, 2014

Hello Maxim,

Does that user have access to the Crucible reviews from within Crucible itself? Also, make sure only OAuth (no impersonation) is used for the Application Link.

Hello Daniel,

1) Yes. User have access to the Crucible reviews. This issue reproduced for me to (I'm Jira Admin and has appropriate access),
Also, please note, that this issue is not a permanent.
Issue reproduced 1 out of 10 times with the same settings.

2) I used configured 'Trusted application' tab and 'OAuth' with enabled 2-Legged OAuth requests.

But issue is still present.

Do you have other ideas?


1) We have OAuth (2LO) authentication.

2) We have Crowd user base, so user log in to JIRA FishEye/Crucible using the same login/pass.

IMPORTANT:

I've tried to reproduced this issue several times, looks like this issue is not a permanent issue. It works as expected on my side 1 out of 5 times with the same settings.

I've also asked non admin users to check it on their side.
Here is the answer:
I was able to see list of reviews one time. Sources were still unavailable.
After that I tried other browsers and as a result non of them (including first Chrome) showed either sources or reviews.

I am having this same problem. Crucible 3.4.4 Jira 6.2.5. No SSO on crucible. Applinks configured as described here.

When viewing an issue in Jira you can open the developer panel and see the commits, okay. When trying to close and reopen it you are getting the error (at least after 3-5 tries). So in general it works but when trying it on the same issue page the functionality breaks. When switching to another issue the authentification works again. Wirred behavior...

We have the same problem. Using JIRA 6.2.7 and Fisheye 3.5.2

If we click Development/commits we normally see the result. But if we do it a second or third time

we are getting the window (you dont have access....) and if that message comes up, it is not possible to see

the commits anymore even after trying 30 times.

Certain time later or next day, it's here again and the game starts from the beginning.

Thanks for rush fixing the problem

 

아래처럼 어플리케이션 링크가 보여야 하는데 

한글 랭귀지 팩이 설치된 경우에는 이 링크가 보이지 않습니다. 

그럴 경우 사용자 프로파일 > 환경 설정에서 언어를 Englsh로 바꿔주면 아래 처럼 링크가 표시됩니다. 

 

이거 알아내는데 3일 걸렸네요 T.T; 

fisheye1.png

ps1

한글 랭귀치 팩따위는 설치하지 않는건데. 개발팀 외의 다른 부서(ex:고객 지원팀)는 지라 사용을 너무 어려워 해서. 젠장. 

 

ps2

아래는 막간을 이용한 홍보입니다. 쿨럭. 

http://www.smilecat.com

http://www.bizhows.com

 

 

 

 

 

We experienced the same issue likeBjörn Kraus today with Crucible 3.10 and JIRA 6.2. Recreation App links partially helped(now I cannot see JIRA issue in Crucible!), submitted support issue with Atlassians.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

545 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you