It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Cannot start plugin: com.atlassian.jira.plugins.jira-healthcheck-plugin"

I have tried every solution mentioned in JIRA solutions and google but nothing seems to be working. I am just installed JIRA server on my own server (CentOS 7) Java 7 and I am seeing following exception in /opt/atlassian/jira/logs/catalina.out. Please any advice you can provide will be greatly appreciated... 


com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.jira.plugins.jira-healthcheck-plugin

 at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:418)

 at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286)

 at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130)

 at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107)

 at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1212)

 at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1188)

 at com.atlassian.jira.plugin.JiraPluginManager.addPlugins(JiraPluginManager.java:150)

 at com.atlassian.plugin.manager.DefaultPluginManager.earlyStartup(DefaultPluginManager.java:573)

 at com.atlassian.jira.plugin.JiraPluginManager.earlyStartup(JiraPluginManager.java:118)

 at com.atlassian.jira.ComponentManager$PluginSystem.earlyStartup(ComponentManager.java:610)

 at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:188)

 at com.atlassian.jira.ComponentManager.start(ComponentManager.java:157)

 at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:43)

 at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:144)

 at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:298)

 at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:194)

 at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:135)

 at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:101)

 at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31)

 at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:99)

 at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:149)

 at java.lang.Thread.run(Thread.java:745)

Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.jira.plugins.jira-healthcheck-plugin [91]: Unable to resolve 91.0: missing requirement [91.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.support.healthcheck)(version>=2.0.11))

 at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)

 at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)

 at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955)

 at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942)

 at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:399)

2 answers

Ok for the people out there who are seeing the same answer. Following is what helped me

A) I had to bump up the memory to atleast 3gb on my linux box

B) Unintalll JIRA and Reinstall the latest version

C) go to following file

/opt/atlassian/jira/bin/setenv.sh  

and increase the limits as follows

JVM_MINIMUM_MEMORY="640m"

JVM_MAXIMUM_MEMORY="1024m"

D) Run these commands

sudo chown -R jira:jira /var/atlassian/application-data/jira
sudo chown -R jira:jira /opt/atlassian/jira/logs
sudo chown -R jira:jira /opt/atlassian/jira/temp
sudo chown -R jira:jira /opt/atlassian/jira/work
chmod -R u=rwx,g=rx,o=rx /var/atlassian/application-data/jira
chmod -R u=rwx,g=rx,o=rx /opt/atlassian/jira/logs
chmod -R u=rwx,g=rx,o=rx /opt/atlassian/jira/temp
chmod -R u=rwx,g=rx,o=rx /opt/atlassian/jira/work

E) Restart JIRA and Voila!! it works like magic.

Please a kind request, if you are reading this answer and tried these steps, please let people know if these steps worked for you as well. Trust me it helps that more than person has confirmed it. Or anything additional if you have done to make it work, please do mentions as it helps us back someday some time wink. Happy Developing...

0 votes

Its saying that current installed plugin for health-check is not compatible and telling to upgrade it  to version>=2.0.11

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

303 views 1 3
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you