project permission not working after upgrade

Hi,

we've recently upgraded from v5.2.4 to v6.3.8 and are finding that some of the user permissions set at project level are not working.  If we delete the user and reassign them then all is well but I don't really fancy doing that for everyone and we can't tell what's working and what's not.

Is this a known issue? Is there a way to refresh them all in one go.

Thanks 

GG

3 answers

0 votes

That's not a known issue as far as I can tell.  I've done similar upgrades and all the permissions come across fine.

What user data directory are you using (Internal, Crowd, LDAP etc)?

We're using LDAP.  It seems to be affecting single users only, groups and roles all work fine.

On the database there is a permission field in the schemepermisssions table and this is set to a number for those that are not working.  If I delete and re-add the user through the UI then the new record has a null in that field, and the permission starts working.  

I have tried just updating that field to null but that doesn't work, only deleting and adding seems to do the trick.

I ran SQL profiler on the database to see if there was anything else getting updated but apart from the audit tables there wasn't.

Obviously I can script up the delete and add but I was just wondering if anyone had any ideas.

Thanks

In the end, I scripted the deletes and inserts in SQL.  Amended the sequence table and restarted JIRA and that seems to have fixed it.

All very strange really!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,956 views 19 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you