It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

new Jira issue view - a custom field disappears from the screen after a second or so

We have a custom field in our Jira project.

Since the "new Jira issue view" was introduced a few weeks ago, we noticed that when entering the issue page, the custom field is seen for a second or two and then disappears.

 

Any idea how to fix this?

1 answer

0 votes

Hi Itay,

Just for us to better understand and help you with this issue, I will make some questions.
Is this a classic or a next-gen project?
What is the type of the project (Software, Business, Service Desk)?
What is the type of the custom field?
Are you the only user facing this issue?
Would it be possible testing using incognito mode or other browsers?

If you are using next-gen, please go to Project settings > Issue types > Select the desired issue type and check if the field appears on the screen.

If it's a classic one, please go to Project settings > Issue layout > Edit layout and check if the field shows correctly.

With this information, we will be able to further investigate what may be causing the issue.

Regards,
Angélica

Hi Angelica.

 

Is this a classic or a next-gen project?  - Classic
What is the type of the project (Software, Business, Service Desk)? - Regular Software project.
What is the type of the custom field? Person selector
Are you the only user facing this issue? No. Seems like other uses don't even see the field at all. Not even for a second.
Would it be possible testing using incognito mode or other browsers? I will try later.

If you are using next-gen, please go to Project settings > Issue types > Select the desired issue type and check if the field appears on the screen.

If it's a classic one, please go to Project settings > Issue layout > Edit layout and check if the field shows correctly. - Yes, it is.

I don't know if something was changed in the Jira cloud, but it seems to be ok now, and the field can be seen...
So it seems like the issue is resolved

Like Angélica Luz likes this

I am having this SAME issue...Please advise

Hi Lacey,

Can you please let me know the same information I asked on my previous answer?

Is this a classic or a next-gen project?
What is the type of the project (Software, Business, Service Desk)?
What is the type of the custom field?
Are you the only user facing this issue?
Would it be possible testing using incognito mode or other browsers?

If you are using next-gen, please go to Project settings > Issue types > Select the desired issue type and check if the field appears on the screen.

If it's a classic one, please go to Project settings > Issue layout > Edit layout and check if the field shows correctly.

Regards,
Angélica

I figured out the issue...please disregard. Thanks!

If it's a classic one, please go to Project settings > Issue layout > Edit layout and check if the field shows correctly.

@Angélica Luz I checked this settings page and the Business Value field is correctly listed as a Primary Field above Story Points, but the field still won't persist once the issue is fully loaded.

Is this a classic or a next-gen project? Classic, with New Jira Issue View enabled
What is the type of the project (Software, Business, Service Desk)? Software
What is the type of the custom field? Business Value (numeric?)
Are you the only user facing this issue? No
Would it be possible testing using incognito mode or other browsers? Yes; I tried it in Chrome's incognito - the field appears while the issue is loading in both the Backlog issue view panel and when viewing the issue as its own page, but disappears once the page is fully loaded.

I figured it out! Custom fields' visibility is controlled by its Configuration Scheme (Jira settings > Issues > Custom fields > Business Value > ••• > Configure > Edit Configuration). I saw that for Business Value, the Default Configuration Scheme for Business Value is set to only show for Epics and Stories – and I kept looking at Bugs and Tasks to see if I enabled it correctly. Thanks anyway!

Hi A-Jay,

Thank you for the details and I’m happy that you found the resolution.

The Business Value indeed is set only to Story and Epic, but it’s possible to change this to show to other issue types according to our documentation.

This field is of type 'Number Field' and is available to issue types 'Story' and 'Epic'. (If you want to make it available to other issue types, edit the custom field context.)

Regards,
Angélica

Like # people like this

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

881 views 7 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you