migrating from ondemand to onpremesis - database version issue

Version 6.3.3.1 onPremesis server installed on CentOS 6.5 linux

After importing our backup from our ondemand site, the jira service will not start. The following is in the Jira (tomcat log):

****************************************************************************************************

Failed to start JIRA due to a build number inconsistency.

The data present in your database is newer than the version of JIRA you are trying to startup.

Database version is: 64000

JIRA app version is: 6331

Please use the correct version of JIRA. You are running: 6.3.3#6331-sha1:d919e5c6aac4bdb845e5512db42aa18387f6a299

****************************************************************************************************

How to I overcome this version issue and will it compromise my data?

4 answers

1 accepted

This widget could not be displayed.

Hi, we have got that problem serveral times. The problem is that the version on onDemand often larger that latest release version on standalone. We do the following - manually edit the xml backup and change the version and build number so the xml restore will "eat" backup from improper version. There are often the problems with changes - so we do the drop of columns that are not part of database anymore and create empty columns using linux regexp change. But there is high probability that you will have to change only those numbers. Please note, that it is often that you are unable to migrate due to plugin version match - either do the same either disable / remove plugin at target standalone instance. I recommend either wait until new release is comming so you will get the match between ondemand and standalone, either do the test migration by the method I've sent to you and then deside if you are ok with the imported data.

Thank you for your post, I'll try it out and see how far I can get.

I didnt have all that many issues, so I just recreated them all by hand for the time being.

Great Alexey! This workaround worked so far. Here is what I changed.

Downloaded backup from onDemand Server

unzip archive

edit entities.xml

Core Application Version 6.3-OD-02-003

Core Application Build # 63300

zip files back into archive

import using web gui. You will still get the warning about the JIRA build # being 6.4, but you can import successfully and login.

Glad that it helped! You can mark this issue answered to close the ticket.

This widget could not be displayed.

May I confirm that you are following the steps from here: https://confluence.atlassian.com/display/JIRA/Migrating+from+JIRA+Cloud+to+JIRA+Server

Yes, after step 3 the web interface asked me to restart Jira. After restarting the service it returned a null pointer exception, I checked the tomcat logs and saw the error in the message about the version mismatch.

Nigel & Cullen, are you guys using the latest download version: https://www.atlassian.com/software/jira/download

yes, 6.3.3.1 is the latest as of yesterday. Is there status on release of a compatible version with OnDemand 6.4.0?

This widget could not be displayed.

Im also having the same issue. Cant import the export from Jira OnDemand to a local server running 6331

This widget could not be displayed.

This issue is closed.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

235 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you