For a few days, we have been facing to a problem if jvm crash of Jira.

We only got a file named hs_err_pid...

No log at all. No suspect.

My questions are : "How to find the guilty ?" A plugin ? Which one ?

It is always in the morning...

May I change the version of the jvm of JIRA in order to upgrade it ?

Thanks for your help.

4 answers

Go to addon manager, enable the same mode and keep watching. If this is not possible, keep disabling the addons one , watch , they try with next and so on

1 votes

Hi Emmanuel,

Usually the hs_err_pid crashes are bugs in the JVM. They are like a Operational System BSOD.

I recommend to upgrade the JVM to the latest version available of 1.7 or 1.8 and if the issue persists, then it must be analyzed what is causing the crashes. You should locate the hs_err_pid file created from the crash, a dump of the error described more deeply, and check the contents. If you need help on debugging the file, please provide it to this question so we can have a look.

Cheers,

Rodrigo

Thanks for your reply. Do you know if it is safe to upgrade the jvm of JIRA without any consequence (support, etc..) ? My JIRA version is 5.2.11. Here is the last logs of the jvm. I tried to google it but no answer . I don't know if you need the entire content . # # A fatal error has been detected by the Java Runtime Environment: # # SIGSEGV (0xb) at pc=0x00007f92a901c8c1, pid=29195, tid=140260395493120 # # JRE version: 6.0_31-b04 # Java VM: Java HotSpot(TM) 64-Bit Server VM (20.6-b01 mixed mode linux-amd64 compressed oops) # Problematic frame: # j mondrian.util.DigitList.ensureCapacity(II)V+0 # # If you would like to submit a bug report, please visit: # http://java.sun.com/webapps/bugreport/crash.jsp # --------------- T H R E A D --------------- Current thread (0x00007f90e001b000): JavaThread "TP-Processor21" daemon [_thread_in_Java, id=38681, stack(0x00007f90eaf54000,0x00007f90eb0cb000)] siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0x000000001538153c Registers: RAX=0x0000000015381530, RBX=0x00000000000000be, RCX=0x0000000579a1af70, RDX=0x000000000000000c RSP=0x00007f90eb0b8f28, RBP=0x00007f90eb0b8f70, RSI=0x000000073cdb21c0, RDI=0x00007f92a900596e R8 =0x00000005973ad920, R9 =0x0000000000000003, R10=0x00007f92b2c83160, R11=0x0000000000000000 R12=0x0000000000000000, R13=0x0000000579a19ddd, R14=0x00007f90eb0b8f98, R15=0x00007f90e001b000 RIP=0x00007f92a901c8c1, EFLAGS=0x0000000000010206, CSGSFS=0x0000000000000033, ERR=0x0000000000000004 TRAPNO=0x000000000000000e

I've tried to search for this error as well but no luck. It seems the crash happened in this class (mondrian.util.DigitList) better explained here: http://javadoc.pentaho.com/mondrian390/mondrian/util/DigitList.html In JIRA 5.2 you can use the JDK 1.7 and I heavily recommend the latest version of this one if you don't have yet. Cheers!

Thanks for your reply but I can not do what you suggested because I am working in a big company with many users. If I disable some plugins, it will not be accepted by users because of the lost of features of jira.

Can you recall all the changes done before the crash started?

0 votes

Hi Emmanuel,

Another way to find out why your application is crashing might be to extract some Thread dumps (https://confluence.atlassian.com/display/JIRA/Generating+a+Thread+Dump). I'd recommend like 8 threads 10 seconds a part so we can further see if anything pops out.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,760 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot