jira - reindex failed with Reindex ALL FAILED error

Hi,

This is what I have done

1. Upgrade Jira Agile to version 6.3.13.1. After that Jira has blocked so I've restarted and everything was ok.

(We have Jira version 6.2)

2. I noticed that I have 250 mails in the mail queue so I've done what I found here:

https://answers.atlassian.com/questions/211906/mails-not-leaving-mail-queue

# Shut down JIRA

# Delete the content of {{$JIRA_INSTALL/work}} directory

# Delete the content of {{$JIRA_HOME/caches/indexes}} directory

# Delete the content of {{$JIRA_HOME/plugins/.bundled-plugins}} directory

# Delete the content of {{JIRA_HOME/plugins/.osgi-plugins}} directory

# Start-up JIRA

# Perform indexing (System > Advanced > Indexing)

3. The indexing finished with :

Indexing completed with 29 errors

Task completed in 1 hour, 14 seconds with unexpected error.

Started 26/May/14 12:26 PM.

Finished 26/May/14 1:26 PM.

com.atlassian.jira.index.IndexingFailureException: Indexing completed with 29 errors
        at com.atlassian.jira.index.AccumulatingResultBuilder$CompositeResult.await(AccumulatingResultBuilder.java:163)
        at com.atlassian.jira.index.IssueIndexHelper.fixupIndexCorruptions(IssueIndexHelper.java:125)
        at com.atlassian.jira.issue.index.DefaultIndexManager.doBackgroundReindex(DefaultIndexManager.java:883)
        at com.atlassian.jira.issue.index.DefaultIndexManager.reIndexAll(DefaultIndexManager.java:308)
        at com.atlassian.jira.issue.index.DefaultIndexManager.reIndexAllIssuesInBackground(DefaultIndexManager.java:360)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.atlassian.util.profiling.object.ObjectProfiler.profiledInvoke(ObjectProfiler.java:83)
        at com.atlassian.jira.config.component.SwitchingInvocationHandler.invoke(SwitchingInvocationHandler.java:28)
        at com.sun.proxy.$Proxy11.reIndexAllIssuesInBackground(Unknown Source)
        at com.atlassian.jira.util.index.CompositeIndexLifecycleManager.reIndexAllIssuesInBackground(CompositeIndexLifecycleManager.java:89)
        at com.atlassian.jira.web.action.admin.index.ReIndexBackgroundIndexerCommand.doReindex(ReIndexBackgroundIndexerCommand.java:39)
        at com.atlassian.jira.web.action.admin.index.AbstractAsyncIndexerCommand.call(AbstractAsyncIndexerCommand.java:59)
        at com.atlassian.jira.web.action.admin.index.ReIndexBackgroundIndexerCommand.call(ReIndexBackgroundIndexerCommand.java:15)
        at com.atlassian.jira.web.action.admin.index.AbstractAsyncIndexerCommand.call(AbstractAsyncIndexerCommand.java:24)
        at com.atlassian.jira.task.TaskManagerImpl$TaskCallableDecorator.call(TaskManagerImpl.java:374)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at com.atlassian.jira.task.ForkedThreadExecutor$ForkedRunnableDecorator.run(ForkedThreadExecutor.java:250)
        at java.lang.Thread.run(Unknown Source)

4. I've searched and found :

https://confluence.atlassian.com/display/JIRAKB/JIRA+indexing+failed+after+upgrade+with+Reindex+ALL+FAILED+error

so I've run :

SELECT id,issuenum,project FROM jiraissue WHERE issuenum IS NULL;

with 0 results

and SELECT * FROM issuelink WHERE linktype NOT IN (SELECT id FROM issuelinktype);

with still 0 results

So I uninstalled the Agile plugin (thinking that this is the problem) and then re-installed it and then performing another re-index with the same result.

I don't know what to do anymore. Please help me. Thank you!

4 answers

1 accepted

This widget could not be displayed.

I fixed it with Integrity Checker...thank you all for posting your questions and your answers .

Thanks for your help, It worked for me too smile

This widget could not be displayed.

Maybe I should do an uninstall to the Agile, then re-index of Jira and the install it again ???

This widget could not be displayed.

I've uninstall Agile ,re-index Jira and I've got the same 29 errors...I've installed Agile again

I've uninstall Script runner, re-index Jira and I've got the same 29 errors...I've installed Script runner again

What else can I do???

This widget could not be displayed.

Can you please let me know how to fix it with Integrity checker.

 

Thanks in advance.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

148 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you