It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

jira-python does not work with cloud jira? Edited

I am in the process of moving from server hosted to cloud hosted JIRA. I have a script which runs a JQL query to get all the outstanding issues for a given project using jira-python. It worked very well for the server hosted JIRA, but I cannot make it work for the cloud hosted jira. This is what I tried:

1) Login fails if I use my atlassian user/password. Doco indicates that this is no allowed for cloud services and to use token instead.

2) Login seems to succeed for user/token (no error messages), but when I do the search query I get an error message saying that no such project exists.

Now, I have figured out this is a misleading error message, and in fact what is happening is that the search request is not authenticated. I figured this out by noticing that I could issue the same search request in my browser and get a response only when I was logged into JIRA. The moment I logged out, the behaviour was the same as I was seeing from my script.

So does this mean that I cannot use this package for Cloud JIRA?

Thanx

Gaby

1 answer

1 accepted

0 votes
Answer accepted

It all works as advertised, I had a number of typos and errors that made it not work

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

236 views 1 2
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you