Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

jira.permission.comment.user = false as property on workflow status does not work

jira.permission.comment.user = false as property on workflow status does not work

it does not disable both comment buttons

Jira - 6.2

Ref:

https://confluence.atlassian.com/display/JIRA/How+to+deactivate+comments+for+closed+issues

5 answers

1 accepted

0 votes
Answer accepted
Pedro Cora Atlassian Team Jul 30, 2014

Use jira.permission.comment.user = denied instead of false ;)

Did not work :(

Pedro Cora Atlassian Team Jul 30, 2014

What is the version of JIRA? I tested on JIRA 6.2.7 and it works.

My bad - it worked without any issue.

Setting the property either to false or denied work. On JIRA 6.3.9+, setting this property will prevent comments on transitions which go to the step/status with this property, due to the bug https://jira.atlassian.com/browse/JRA-40997.

jira.permission.comment.user = denied  

is not working for JIRA version 7.6.4, any idea ?

I try jira.permission.comment.user ->denied  and  works fine! in Jira 7.6.7

None of these seem to work in 8.3 is there a page the just lays out all the status proprieties I can use? 

I agree, we should have this listed out somewhere.

Does this apply also to properties of transitions too? I want to hide Comment field on the transition screen, but none of the Properties below didn't work (in Jira 7.8.2)

jira.permission.comment.denied = true

jira.permission.comment.user = false

jira.permission.comment.user = denied

Also, none of the other suggested solutions  with javascript etc. didn't work, it's quite weird that such simple thing as to hide field on the transition screen is so insanely complicated...

Hi Nikola,

 

try with this:

jira.permission.comment = false

it's working for me

 

Regards,

Jacek

What's about latest cloud version?  Nothing working.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you