Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

jira.field.resolution.exclude doesn`t work

I tried this short script to remove some resolutions but no one was removed.

I inserted this in Property Key of the workflow step. I doubled checked the resolution ID to make sure to use a proper value. Everything seems to be set as it needs.

I tried jira.issue.editable with false value and it worked.

I`m getting so frustraded.

Does anyone knows how to handle this issue ?

4 answers

1 accepted

1 vote
Answer accepted

Leading or trailing white spaces need to be trimmed in workflow transition properties entry boxes.

for examle

"jira.field.resolution.exclude " does not equal "jira.field.resolution.exclude"

I took care of that. Thank you

you have to use the property on let's say the resolve "transition" where the field is present on the screen and it should work.

Cheers Christian

Thanks a lot. I tested and it worked very well on a transition property.

My point is to remove the transition from the litte list that is shown up in edit window of the issue.

Bellow is the list that i mean.

https://confluence.atlassian.com/download/attachments/313467778/Resolution.png?version=1&modificationDate=1354859273339&api=v2&effects=border-simple,shadow-kn

 In case this helps anyone else who is struggling to work this out.

The property "jira.field.resolution.exclude" ONLY applies to Transitions in a Workflow.

You can set this property on a Status node, but it will have no effect.  Further, Jira will not warn you that the property is not applicable. It just ignores it.

Background: Every Jira Issue has a current State.  A Workflow is a directed graph, which shows the valid issue States (nodes), and the Transitions (edges) which link them.  Transitions specify which States can move to which other States.

In the usual Issue view, the Transitions which are valid for the current State appear in the form of buttons, below the Summary line and above the Details section.  If there are more than 3 outgoing transitions, then the third/last button will be named "Workflow" (instead of the name of a transition). This "Workflow" button will have a drop down select list containing the third, fourth etc transitions.

 

When a user views an issue, and clicks a transition button which leads to a State which is in the Done (green) category, then if there is Screen defined for this, this Screen will have a"Resolution" field.  This is a mandatory field, and the values in the drop down list will normally be every Resolution within Jira (since they are global).  However the Resolutions which show up are affected by the 'exclude' property.  

Note that you have to use IDs, which you can see if you go to edit a Resolution - the ID is in the CGI parameters.  This trick works for other attributes too.

Since this property applies to Transitions, and not to the source or destination States, then you have to edit EVERY transition which leads to ANY Done (green) state, and add the property to exclude Resolutions from the resulting screen(s). 

Looking at this from a glass-partially-full perspective, I guess it means you have the granularity to explictly make different resolutions available, depending upon the current state and the destination state.

But in Jira, Resolutions are global, and this property is the only way to sort of make them per-project.    If you just want to exclude a number of Resolutions which are inappropriate for a project, then editing every terminal Transition can be a lot of work,  especially if you have multiple workflows, with multiple Done states, and lots of transitions which lead to them...

0 votes
Joe Pitt Community Leader Aug 27, 2017

I suggest using the 'include' property instead for a couple reasons; 1. I've found there is usually a fewer number of resolutions I want to include than exclude, and 2. If I add a new resolution I only have to update the workflow where it is needed.

How do you do multiple?  It works for one ID but not for multiple ID.  I have tried comma delimited with and without a space between the IDs.

Like # people like this

Hi @Joe Harmon, As this was from over a year ago perhaps you have figured this out. I was having the same issue but after some trialing of different methods I found one that works. The list of IDs that you want to include or exclude (depending on property) needs to be in a comma separated list with no spaces. For example, resolution IDs listed need to look like this: 10100,10200,10300.
As you can see, no spaces between the resolution IDs.

Like jira.test likes this

Yeah I figured it out.

Thanks though, @Peter Kerrigan

this helped me!

Like Peter Kerrigan likes this

Hello guys! I have trouble figuring out how to set jira.field.resolution.exclude values properly. I added this as a property key to a transition and tried with values e.g. 1 or 2, but no luck - the Resolution list still shows all values. If however is replace the above key with jira.field.resolution.include, nevertheless of the values e.g. 1,2 or whatever, the Resolution list is empty. So I guess the keys work, however, I cannot find the correct Resolution id values. Where I can find them in Jira?

So are you trying to set these properties using the resolution name @Angel ? Try setting the property value using the resolution IDs. These can be found at the end of the URL when you select the Edit action from the resolution page in the Jira admin panel. Typically resolution IDs take the form of 10100, 10101, 10102, etc. though sometimes you will have a resolution ID that is only one number (i.e. 3, 4, etc.)

@Peter Kerrigan- actually I was trying to set ResId e.g. 1 or 2 or 10100, but no luck. So I guess the values I use are not the right ones. Not sure I follow you - how to find Resolution IDs in Jira (we use Cloud) - I would very much appreciate it if you can describe this part a bit more in detail. Thanks!

@Angel Todorov Let me start by addressing the first problem of finding resolution.

To find Resolution ID in Jira Cloud follow these navigation steps:

  1. Select the cog at the top right of your window to access Jira settings, select Issues.
  2. Select Resolutions from the settings list on the left side of admin panel; you will see the list of resolutions on your instance.
  3. Select edit on your desired resolution.
  4. Once in the edit view for the selected resolution, the resolution ID will appear as a number at the end of the page URL.

To properly set transition property jira.field.resolution.exclude or jira.field.resolution.include, you need to ensure that the listed resolution IDs are typed out in a comma separated list with no spaces in between ID values. For instance, the property value would look something like: 10100,10101,10102,10103

Notice how there are no spaces between the resolution IDs? This format works for both of the aforementioned transition properties. 

I hope that this helps! 

Like Angel Todorov likes this

Thanks @Peter Kerrigan - you saved my day! As I suspected, the issue I have got was related to finding the proper Resolution ID values - in my case, they have started from 10000. Once I set the right value, all is good.

Like Peter Kerrigan likes this

I would recommend always using include vs exclude.  If you use exclude, any time a new resolution is added you will have to go exclude it if you are not using it.

Like Peter Kerrigan likes this

I can confirm that both Inlcude and exclude does not work. 

What do you mean @Timothy Bassett ? What is not working for you?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you