Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

jira code block macro not working after update to Jira 8.4.1


The code blocks aren't formatted after updating to a newer version.

Code blocks are now visualized as :

// Some comments here
public String getFoo()
return foo;


While lists are visualized correctly.


The two wiki plugins are enabled


All renderer plugins are enabled:


What could be causing this behavior?

2 answers

1 accepted

0 votes
Answer accepted
Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 18, 2019

Hi Dieter,

I understand that you recently upgraded Jira to 8.4.1, but since that time you seem to be unable to get the {code} macro to properly format within Jira fields that use wiki markup (like comments or description.

From looking at your screenshots, I can see that while the plugins are enabled, you appear to have some modules of that plugin that are disabled.  You can click that modules enabled link on the right side to see which modules are enabled/disabled, like so:

Screen Shot 2019-10-18 at 1.50.59 PM.png

I'm betting that your environment seems to have the code module disabled.  You should see a button on the far right side to enable that module.  Try to click that to re-enable this.

I'm not sure what would have caused this, aside from an administrator having disabled these.  But try this and let me know if this helps.



Oh, seriously!


It's working!

0 votes
Kieran Ryan
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 26, 2023

Thanks for the tip about using {code} as markup for code blocks - other google articles were recommending back ticks which weren't working for me.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events