install JIRA on windows server 2008 R2 SP1

I am trying to install JIRA on windows server 2008 R2 SP1, logged in as an administrator.

After running the install file for JIRA 5.2.4, localhost:8080 could not be found.

further examination revealed that start_service.bat failed as the service with the correct name could not be found. Presumably this means that the service was not created correctly as part of the install package.

After running start_bundled_jre.bat from the install directory, and waiting for it to finish, localhost:8080 could then be found and I proceeded with the install.

I am concerned that the lack of the service will mean that JIRA will not automatically start when the machine restarts, so am wondering what I should be doing to resolve this.

5 answers

1 accepted

Accepted Answer
0 votes

Andrew,

Your JDK/JRE must match the Jira installer you downloaded. You indicated you downloaded the 64bit Jira installer but, have a 32bit jdk installed. The service is probably attempting to use the 32bit jdk as it is the java home and fails to start as the Tomcat bundled with Jira 64bit is a 64bit and not compatible with the 32bit jdk.

Running the bundled jdk bat file works because the jdk bundled with the 64bit installer is a 64bit jdk.

You need to either:

uninstall the 32bit java sdk and install a 64bit java sdk.

Run tomcat7w //ES//JIRA and in the JAVA tab set the Java Virtual Machine to <jira_path>\jre\bin\server\jvm.dll

That would be logical, but I have seen in multiple places in Atlassian documentation, including here:

https://confluence.atlassian.com/display/ATLAS/Dragons+Stage+1+-+Install+JIRA

that 32bit jdk is the way to go, so I installed the 32bit.

I'll give the 64 bit jdk a try, it cant hurt.

uninstalled 32 bit jdk

uninstalled jira

installed 64 bit jdk

set JAVA_HOME

installed jira via 64 bit installer with default settings

Works.

Can you give the link of the doc you referred to?

I went back and read the guide and it seems there is a disconnect in it. They do recommend the 32bit jdk, I personally don’t see why but, I’ve only dealt with large installs. I suppose if you are setting the jvm mem under 1.5gb it could make sense to stay with the 32bit version. The disconnect comes when they advise you to download a 32bit or 64bit version to match the OS version, not the JDK version. You could very well run a 32bit JDK on a 64bit Windows but, you would need to install 32bit Jira to go along with it.

Tecken, since you responded earlier perhaps you'll see this and someone from Atlassian could correct the guide to indicate that the Jira needs to match the version of JDK (32 or 64 bits) you are using and not the OS version?

https://confluence.atlassian.com/display/ATLAS/Dragons+Stage+1+-+Install+JIRA

In "Step 4. Install Jira", it says:

"If you are running 64-bit [Linux|Windows], download the [Linux|Windows] 64 Bit Installer file for JIRA 5.2.

If you are running 32-bit [Linux|Windows], download the [Linux|Windows] 32 Bit Installer file for JIRA 5.2. "

But, in" Step 1. Install Java", it says:

"If you are running 64-bit Windows, we recommend that you use 32-bit JDK rather than the 'x64' JDK. The 32-bit version will use less memory. You do not need the 64-bit JDK unless you are running a very large server."

Dragons document is a learners document for getting used for all the products from Atlassian (basically the integration part). That is actually not the document to be referred for production instance installations.

Renjith, regardless of who the document is aimed at, it still has information in there that can lead to installation issues.

I would think particularly if it is a learners document that you would want to limit the number of potential issues arising?

This knowledge base article also suggests using a 32bit jvm in order to get the service running on 64bit windows

https://confluence.atlassian.com/display/JIRAKB/Problems+Installing+JIRA+as+a+Service+on+Windows+64bit

This knowledge base article which I also referred to

https://confluence.atlassian.com/display/JIRA/Running+JIRA+as+a+Service#RunningJIRAasaService-ManuallySettingupJIRAtoRunasaService

says

If you are running a 64-bit version of Windows, please note that Apache Tomcat cannot run as a Windows service if you are using a 64-bit JDK/JRE (see JRA-12965). Please ensure that you are using a 32-bit JDK/JRE.

So bertween dragons and multiple Atlassian KB posts, I dont think that I was being unreasonable in installing the 32bit java.

Ironically had I not looked at any guide, I would have used the 64 bit java and everything would have worked.

You are right, that bug is closed as not reproducible. Will get this checked.

Updated the doc.

Although I am using 64 bit windows, I followed the install instructions in the Atlassian Dragon Slayer Stage 1 and used a 32bit JVM, so unfortunately this wont help.

0 votes
Yew Teck En Atlassian Team Jan 03, 2013

Hi Andrew,

You may want to try:

  1. Setup JAVA_HOME environment and point to the bundled JRE
  2. Remove the JIRA Services that setup by the installer package
  3. Setup the services again manually

Setting the JAVA_HOME envirnoment variable to the bundled JRE (I assume that you mean the one in C:\Program Files\Atlassian\JIRA\jre) means that I cant run the service.bat command required to setup the service manually.

Seting the variable to the jdk I installed prior to JIRA (C:\Program Files (x86)\Java\jdk1.6.0_38) allowed me to setup the service following the steps in Setup the services again manually.

After setup, I could see the service by going to Control Panel>Administrative Tools>Services, but it had not been started.

Trying to start the service from the Services window, or from the command line failed.

I tried restarting the server as the service was set to start automatically, but this too failed to start the service.

Thanks for the responses thus far, but I've had no joy, so i tried starting again. (uninstalled JIRA, then deleted contents of C:\Program Files\JIRA\, deleted PostgreSQL database called jira, recreated empty database)

  • 32 bit java jdk installed in C:\Program Files (x86)\Java\jdk1.6.0_38, this is also what the the JAVA_HOME environment variable is set to
  • downloaded 64 bit installer for JIRA 5.2.4 for existing customers as I already have a licesnse key.
  • Ran installer as administrator, selected Express install, so standard ports would be used. (nothing else is using :8080)
  • No errors with install, after installation, selected launch JIRA in browser
  • :( no dice, localhost:8080 cant be found
  • Checked Services (Control Panel>Administrative Tools>Services) there was a service called Atlassian JIRA, with description Atlassian JIRA 5.2.4, set to start automatically.
  • Clicked on Start the service from left bar, and apparently I need to contact the service vendor referring to service-specific error code 0. Which I assume means a generic "I just barfed" code.

OK, so following Setup the services again manually

  • opened a cmd window as adminstrator
  • >tomcat7 //DS//JIRA090113191941
    (no idea what the numbers mean, but obtained the name of the service by right click>properties in the services window)
  • The JIRA service is removed from the list of services
  • run C:\Program Files\Atlassian\JIRA\bin>service.bat install JIRA.
    ...The service 'JIRA' has been installed.
    So this is good I guess
  • There is now a service called Apache Tomcat JIRA with description Atlassian JIRA 5.2.4, startup type = Automatic, but not currently running. Tried to start, but still no dice.
  • Figured that there is no point configuring the service with extra memory etc if it can't even be started.

Ran C:\Program Files\Atlassian\JIRA\startup_bundled_jre.bat, tomcat started

  • localhost:8080 now loads and JIRA setup can be continued

However, I am still back to square 1 as JIRA is not installed as a service. Any ideas??

0 votes
Yew Teck En Atlassian Team Jan 08, 2013

Hi Andrew,

Most likely you're hitting into a known bug of windows installer in JIRA 5.2.x: https://jira.atlassian.com/browse/JRA-30699

So, you may want to have a look into this KB article https://confluence.atlassian.com/display/JIRAKB/JIRA+Service+Fails+To+Start+in+Windows+-+Is+Not+a+Valid+Win32+Application

In there, check the common-daemon.log as well as the event log of Windows to see if you having the same log entries. If it's the same, you may want to try the resolution in the KB article.

Check the existence of jvm.dll file. If it exists, try to change the %JAVA_HOME% to the bundled JRE of 64bit JIRA, remove the existing and reinstall a new service. After reinstalling the service, try to start it again.

I hope it do works out for you. Otherwise, it would be best to raise a support issue with us at https://support.atlassian.com and we shall further help you to investigate the problem.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

45 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you