It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

how to resolve this problem while doing an upgrade..

Caused by: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:ChangeItem][oldstring,2011-01-08 21:49:00.0][field,SLA Response Date][id,214675][fieldtype,custom][group,40719] (SQL Exception while executing the following:INSERT INTO changeitem (ID, groupid, FIELDTYPE, FIELD, OLDVALUE, OLDSTRING, NEWVALUE, NEWSTRING) VALUES (?, ?, ?, ?, ?, ?, ?, ?) (ORA-00018: maximum number of sessions exceeded
))

3 answers

1 accepted

3 votes
Answer accepted

I'm not an authority on this, but I think ORA-00018 refers to the total number sessions the server accepts. Once this error is thrown, now new sessiosn on the server are permitted. to check your runing values log into your serve, on a linux system it's something like:

sqlplus '/as sysdba'

once logged in type:

show parameter sessions
show parameter processes

these two commands will list sessions / processes. if you need to increase then

cd $ORACLE_HOME/dbs
vi init.ora (or similar)

change value for session. then stop and restart the database.

You could try increasing the <pool-size> parameter in <jirahome>/dbconfig.xml.

i am performing an upgrade on a unix box by an xml.file, i've configured the DB connection using the JIRA configuration tools, which saves all the detail on the config/server.xml file. browsing on the atlassian site i got to this page:

http://confluence.atlassian.com/display/JIRA043/Incorrect+database+type+specified

which says that:

"

Upgrading JIRA?

This situation is potentially problematic, because the newer version of JIRA may have added tables or columns with incorrect data types to your existing database schema.

The safest solution is to start a new database, and import an XML backup made before the upgrade.

"

so how can i do that?

http://www.techonthenet.com/oracle/errors/ora00018.php

offers "You can shut down Oracle, increase the SESSIONS parameter in the initialization parameter file, and restart Oracle."

Alternatively you could try to get JIRA to use LESS connections in its connection pool.
You can edit the <pool-size> parameter in <jirahome>/dbconfig.xml as Jamie suggests, but you should DECREASE it, not increase it.
If you prefer GUIs over config files, run bin/config.sh (config.bat on Windows) from your JIRA install directory.
Select the "Database" tab, edit the "Pool Size" and save.
You need to restart JIRA for the new DB settings to take effect.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you