??? displaying in Traffic Light status

not sure if anyone has run into this, but in Jira we are seeing four question marks being displayed for a Traffic Light status (three within the color box and one to the right). The color box is displaying proper color, just seeing the question marks. I am assuming it is a data issue or we need to "re-index" or something of the like. Any ideas?

2 answers

1 accepted

In addition to reviewing all Nic's suggestions, we tried rebooting Jira as well. The display issue from Traffic Light in the dashboard (fine in the ticket detail itself) still persists. I am going to close this question and open a ticket with Traffic Light, or the like, and proceed from there.

0 vote

How are you generating the traffic-light status? It's not something Jira does natively (unless you're describing something I haven't quite recognised). Could you explain which plugin it is, or give a bit more detail if it's not a plugin?

Sounds like a display problem in the plugin, rather than a field or indexing error.

Have you checked that the version of the plugin is good for your version of Jira? Any upgrades available?

went that direction too... no go. We have a Production version of Jira (where the problem lies), a QA version of Jira (all good there) and a Development version of Jira (all good there too), all instances have the same version.

I agree, sounds more like a plugin issue, but can't replicate it on the other systems so I am drawing a blank. Will keep digging along those lines.

Thanks Nic. With some further investigation the display issue has been isolated to the Dashboard view only (fine in an individual ticket). It is the Traffic Light plugin. It is like it's displaying the ??? for unknown characters, but what is odd is, again, it appears fine in the ticket itself, just funky in the Dashboard.

We tried removing the field from the Dashboard and reinserting and that did not work, we tried re-indexing (no go there too), and even building a new dashboard view with that field (that uses the Traffic Light plugin), but no fix there, still displays the question marks.

Very random, so I thought I would ask to see if anyone has run into it.

Ooh, now that tickles a memory - having the same plugin work differently in different systems doesn't happen often, but it can. I've seen it with something I wrote once - worked fine on all the decent operating systems, but failed when on Windows!

Worth looking at the differences between the systems, obviously, but I'd start by looking at things that might cause different rendering, as I've seen odd things happen when Java character settings are different. Look at the regions and languages java might be using (e.g. utf-8 - that's bitten me a few times)

therein lies the problem, ALL systems are on same hardware, linux boxes with Apache, etc. I think a simple "reboot" of Jira is in order to see if it solves the issue. Thanks for your assistance Nic. I will report back when I find a solution that worked.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,203 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot