Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,291
Community Members
 
Community Events
168
Community Groups

cannont un-link

I have a task ticket that I cannot un-link from an EPIC.

The ticket is a task and appears to be configured as BOTH a child issue of an epic and a subtask of the same EPIC simultaneously, this is preventing me from unlinking it from the parent epic.

How do I unlink it?

1 answer

1 accepted

0 votes
Answer accepted

Hello @Timothy Ralphs 

Welcome to the community.

Can you provide a screen image of the Epic that shows the one issue is linked twice?

Is this for a Company Managed or Team Managed project?

I suspect that what you have is an issue that started as a sub-task and got converted to a Task.

hi, @Trudy Claspill Thanks for your response.

As you can see, there is no small X next to ed-647 to unlink it, and I have tried a dozen other ideas, and my ADMIN and I cannot figure it out.

Capture.png

Well, at first I thought this must have happened with a conversion of sub-task to story, but I have not been able to replicate that by using the Convert option available in the ... menu in the UI. At least not in issues in a Company Managed project.

If an issue that is a child of an epic is converted to a sub-task, you can specify the issue key of an Epic as its parent. But, the Epic Link field is cleared so the issue only shows as a sub-task of the Epic. If you convert a sub-task in an Epic to a story, then the "parent" field is cleared and the issue no longer shows as a sub-task of the Epic.

It also appears to no longer be possible to create a sub-task directly in an Epic. There is no longer a "Create Sub-task" option when you are viewing the Epic.

At this point I'm suspicious if there could be an automation rule or script that has improperly set the "parent" field on this issue so that it appears to be both a child Story and a sub-task of the Epic.

There would be no Delete option in the sub-task line item because you can't "unlink" a sub-task without specifying a new parent for it.

There is no Delete option in the Child Issue line item because the way to remove a child issue from an Epic is to update the Epic Link field (in a Company Managed project) or use the Backlog screen to drag the issue to the Issues without Epics section of the Epics panel.

If the issue really is a Story, and not a Sub-task, then there are two ways I think you might be able to fix this.

1. Convert the story to a sub-task and set the Epic as its parent. Then convert it back to a Story. That should clear the Parent field. Then update the Epic Link field to add it back as a child of the Epic.

2. I think you might be able to clear it by creating an automation rule and using the Edit Issue advanced option to clear the parent field with JSON. I haven't tried that, so I'm not positive it will work.

Thanks, I'll look into and try this and let you know.

That worked thanks a bunch

That's great!

Which option did you use, 1 or 2?

If your problem has been solved, please mark the answer as Accepted to help other community members find posts that have working answers.

converting to a sub-task did not work. It says "already a sub-task" while it is presented like a task. I went to the right pane and with the ... menu, I selected "see the old view". Then I use a "convert to task" button and it unlinked by itself (epic link was empty).

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Atlassian Community Events