atlassian-connect-play-java: can not migrate to the JSON

I need to migrate my plugin: https://marketplace.atlassian.com/plugins/my_work_calendarto the new JSON module descriptors and JWT and I stuck here.

I used old xml descriptor + oauth version of the atlassian-connect-play-java. Now when I swithced to the freshest verison of the atlassian-connect-play-java and created the appropriate JSON descriptor, I am not able to install the plugin to the local JIRA.

To simplify I started wtih the tutorial: https://developer.atlassian.com/static/connect/docs/guides/getting-started.htmland still get the error:

On the manage Add-ons page I get "Not authorized to install add-on http://localhost:9000/.". When I debug the UpmClient.class I see the following error:

{"type":"PLUGIN_INSTALL","status":{"errorMessage":"The add-on at {0} cannot be installed on this OnDemand instance.","source":"http://localhost:9000","done":true},"links":{"self":"/jira/rest/plugins/1.0/pending/d87d0d31-2907-48e1-9d51-d8494b3f58bf"},"timestamp":1402127729240,"userKey":"admin"}

The JSON descriptor looks like:

{
     "name": "Hello World",
     "description": "Atlassian Connect add-on",
     "key": "com.example.myaddon",
     "baseUrl": "${localBaseUrl}",
     "vendor": {
         "name": "Example, Inc.",
         "url": "http://example.com"
     },
     "authentication": {
         "type": "none"
     },
     "version": "1.0",
     "modules": {
         "generalPages": [
             {
                 "url": "/helloworld",
                 "key": "hello-world",
                 "name": {
                     "value": "Greeting"
                 }
             }
         ]
     }
 }

Please help me. I would be very thankfull if you point me where to look and debug.

1 answer

1 accepted

Hi Volodymyr,

It looks that your JSON is configured right based on Atlassian Documentation.

However it’s very hard to help you based only on these information, to test if it’s not some issue on your local JIRA to import this plugin. I would ask you to try the simplest plugin example on the documentation instead of your plugin, then we’ll be able to know if your local JIRA can import the most simple example of the atlassian documentation.

Any other steps that you have tried before that you want to share will be welcome to better understand what you have already tried and what I can do further.

Kind Regards,

Henrique Lechner

Hi Henrique,

The problem was with new development jira configuration. The config I copied from https://developer.atlassian.com/static/connect/docs/guides/getting-started.htmldoes not work:

atlas-run-standalone --product jira --version 6.3-OD-03-012 --bundled-plugins com.atlassian.plugins:atlassian-connect-plugin:1.0.2,com.atlassian.jwt:jwt-plugin:1.0.0,com.atlassian.bundles:json-schema-validator-atlassian-bundle:1.0-m0 --jvmargs -Datlassian.upm.on.demand=true

I reverted to my old config and plugin started working:

atlas-run-standalone --product jira --version 6.2-OD-08-034 --bundled-plugins com.atlassian.plugins:atlassian-connect-plugin:1.0.0-rc2,com.atlassian.jwt:jwt-plugin:1.0-m8,com.atlassian.bundles:json-schema-validator-atlassian-bundle:1.0-m0,com.atlassian.upm:atlassian-universal-plugin-manager-plugin:2.15 --jvmargs -Datlassian.upm.on.demand=true

I am not sure if it's my "private issue" or there are some troubles with the freshest JIRA config.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,755 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot