Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


You have specified a database that is not empty, please specify an empty database.

I had Jira working using a postgresql database, but as it was the only DB in postgres I made the (eventful) decision to switch to MySQL. I followed the setup  instructions and specified a completely empty database, but now I receive the error message: "You have specified a database that is not empty, please specify an empty database. If you want to upgrade an existing installation, please follow these instructions instead." I ran and after entering the MySQL information, I ran its test and it worked fine. However, when I restart Jira it starts in the setup routine, and when I enter the identical MySQL information for the empty database, it fails with the above message. When I copy the saved version of dbconfig.xml for the postgresql database, Jira still starts in the setup routine. When the setup routine starts and I select "My own database" for the database connection, it is empty (as if it didn't read the dbconfig.xml file).

How can I get Jira running with either the old postgresql database or a new MySQL database?! Thanks in advance...

1 answer

1 accepted

0 votes
Answer accepted

I figured out my mistake. My dbconfig.xml permissions were set incorrectly. Something that should have been checked earlier...


Could you please share the changes you made to dbconfig.xml file

I found the problem was my dbconfig.xml file had an owner and group of root with file permissions set so only the owner could read it. I changed the owner from root to jira, which allowed it to be read.

Like Munesh likes this
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Oct 03, 2023

yes its worked for me as well

Suggest an answer

Log in or Sign up to answer