Why is the Workload report also showing tasks that are marked as "DONE"? Edited

Hi,

As per Title, when I select the workload report, the report shows also the Tasks marked as "DONE".

Now, I created a new filter that only shows issues with a certain status:

assignee = admin AND status in (Open, "In Progress", Reopened, Resolved, "Waiting for support", "Waiting for customer", "Under Testing", Escalated, "Work in progress", "Under investigation") AND project = BEAK

Is there any way to apply this filter for once so that every time I open a workload report it will be applied to the search? 

PS: Also when I open the "Reports" page, there is a user(com.atlassian.servicedesk.embedded) that I do not want to appear in this list.(Refer to screenshot)report.png

I tried deleting this user but it says that I can't as he is a System Administrator User(So am I as far as I know).

user.pngThank you very much for your help.

1 answer

0 votes

Hi Beakon,

In JIRA, issues without a Resolution Field is still considered unresolved, hence being included in your report.

Can you please try marking the Resolution field of some of the DONE issues? Then validate if they are displayed on the report.

Refer to https://confluence.atlassian.com/jirakb/resolutions-are-not-set-225122076.html

Thank you

Bhushan

I tried adding a Update issue field post function, but resolved is not coming as an option, as for this workflow we are using "Done" instead of resolved.

report.png

Hi Beakon,

As long as the Resolution field has a value, JIRA will consider it resolved. You can set it to Done.

However, if you would like to create a new resolution, you can do so in the Administration console. For documentation, refer to https://confluence.atlassian.com/adminjiraserver073/defining-resolution-field-values-861253253.html

Hope that helps.

Thanks

Bhushan

This fixed it for me, thank you very much.

Can you please advise regarding the 2nd part of the original post please? Thanks

Hi Beakon,

Firstly, we do not recommend deleting any user. Always choose to deactivate a user.

Please try the below on a test instance before applying on production.

Can you please check the project permissions. Specifically, Assignable User permission. If the user is any of the groups/roles with assignable permission, remove them from the group.

Verify that the new changes does not impact any existing automation or conditions you may have.

If this does not resolve your issue, I would suggest raising a support ticket with Atlassian.

Please mark the question answered if it helped you :)

Thank you

Bhushan

I tried removing the user from the group it was currently in but nothing changed.

I checked the assignable user permissions and this is what comes up. The user is an administrator.Thanks

test.png

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

467 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you