Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why does "was in"-function not work for assignee anymore? Edited

Hey guys,

I'm having trouble with some jql-filters since friday. They contain the function assignee was in (membersOf("")) and it provides an invalid value since friday. Worked out fine before and I tried with other groups, still same problem.

Is this a temporary problem? Is there a fix for it?

Or any ideas how to change my jql to get tickets which were assingned to a member of a specific group?

Here the error message:
A value provided by the function 'membersOf' is invalid for the field 'assignee'.

Thank you very much!

2 answers

0 votes
Pavel Junek Community Leader Mar 01, 2021

Hi @Trabaldo Lena_ Emanuela,

Welcome to Atlassian Community!

Can you please write the error that Jira is showing you?

For me it works e.g.:

project = "Test project" and assignee was in (membersOf("jira-administrators"))

The group you are looking for may have been deleted.

Pavel

Hi Pavel,

I've added it to my post.

Also I tried with assignee in membersOf("") and it worked with that group.

Thank you!

Pavel Junek Community Leader Mar 01, 2021

Ah, thank you for adding the information :-).

It's weird behavior. It occurs to me that this may be related to this error: https://jira.atlassian.com/browse/JRACLOUD-65110 (The commentary says: Affects also JIRA server...)

0 votes
Daniel Ebers Community Leader Mar 05, 2021

Earlier this year we came across exactly this.
It turned out to be: https://jira.atlassian.com/browse/JRASERVER-71654

It started to fail when a specific users was inactivated - until this is not the case the query works but then breaks.

A colleague mentioned that the operator is not supported as per documentation:
https://confluence.atlassian.com/jirasoftwareserver/advanced-searching-functions-reference-939938746.html#Advancedsearching-functionsreference-membersOfmembersOf()

So, in summary - yes, it works but it is not considered "reliable".

Cheers,
Daniel

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you