Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,537
Community Members
 
Community Events
176
Community Groups

Why Multibranch Pipeline job name takes only 32 character?

Pappu I'm New Here Nov 25, 2022

When I build a job using Multibranch pipeline, Jenkins is not creating workspace repository which is more than 32 character. It trims the character from starting of the job name.

Job name: multi-branch-jenkins-pipeline

Branch: Dev

what i want jenkins to create workspace: multi-branch-jenkins-pipeline_dev

what Jenkins create: iple-branch-jenkins-pipeline_dev

What i tried Djenkins.branch.WorkspaceLocatorImpl.PATH_MAX=40 Didn't Work

 

1 answer

Hi, I have the same issue. Also tried to set MAX_LENGTH, both to 0 or large number, but there is no change in Jenkins behavior. I would appreciate any suggestion.

Suggest an answer

Log in or Sign up to answer