It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Which file encoding should I use for importing CSV having German (non-Ascii) characters?

Hello,

 

Jira is throwing the following warning when trying to import a csv file ( jira project from test instance:

"The CSV file you uploaded contains non-ASCII characters. Make sure to set the right encoding."

 

Both Test/PROD instances default language is English. Configuration of both the instances is exactly the same. 

 

Please suggest a solution.  

2 answers

0 votes

Hello Phani,

 Welcome to Atlassian community.

I believe you might be facing the following bug, which also happens when the personal language of the user importing the file is configured to Deutsch:

CSV External system import is not working if uploaded file contains non-ASCII characters and default language is not English

That been said, I recommend you to try the following steps:

- Navigate to your JIRA Application > Click in your profile picture at the bottom-left corner > Personal Settings:

Screen Shot 2019-06-18 at 16.52.26.png

- Select the language English (United States) > Save Changes > Try to import the file again. If the language is already configured to English, try to move it to another language, save it and move it back to English (United States).

Screen Shot 2019-06-18 at 16.54.17.png

Let me know if it works for you.

@Petter Gonçalves 

Hi,

 

Thanks for the suggestion. I tired it and it didn't work. 

I updated the personal language to English in both instances.

Generated a new CSV file.

Tried to upload the file and then I see the same error.

 

Please advise.

Have you tried opening the CSV in excel, and then doing a "Save as", then clicking "Tools" and then "Web Options..." (Screenshot 1). When the Web Options window opens, go to the "Encoding" tab and then selecting "Unicode (UTF-8)" from the "Save this document as" drop-down (Screenshot 2). Click "OK", then save the file and use that new file to import. I ran into this same problem, and that works for me every time! Let me know!

SCREENSHOT 1 - 
image.png

 

SCREENSHOT 2 - 

image.png

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you