When exporting Jira ticket field information, all data is merged into 1 column

Danilo Simic July 10, 2023

Hello everyone,

One user has reported that when he tries to export Jira ticket field information, all the information is merged into column A of the excel file.

The export was done using the CSV export and "my default" option was picked. All the information is present but it is merged into 1 column.

Any ideas on why this happened and how to solve it?

Thank you for the help.

1 answer

1 accepted

0 votes
Answer accepted
Dan Breyen
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
July 10, 2023

Hi Danilo, based on your information, I tried 'Export CSV (my defaults)' and 'Export Excel CSV(my defaults)' on my cloud site and the information imported into Excel as expected. 

Have you tried it yourself to see what happens?  Can you watch this user walk through the steps to see what's happening?  Maybe they're doing something slightly different than the expected workflow.  Have you tried another browser to see if that makes a difference?  

I took a quick look at Atlassian's Jira site (jira.atlassian.com) and didn't find any outstanding issues that seem related to this.  

Hope that helps.

Danilo Simic July 10, 2023

Hello Dan, I tried logging in as that user and it worked fine, I also left instruction on how to perform the export.

A few minutes ago I got feedback that it did not work again. The user is a C level manager so I can not schedule a call soon, that is why I resorted to asking here.

1.PNG

Here is a screenshot of how the information looks like, maybe it can help. This is after the affected user had performed the export.

Aron Gombas _Midori_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 10, 2023

The cell value in the top shows that the commas are correctly added, so the CSV file itself seems valid. Maybe your spreadsheet tool does not split at the ',' characters, but something else line colon. Try to configure that when importing.

Or, if you don't want to waste time with it, you can just use the Better Excel Exporter app. It produces an XLSX file, it will just work.

Danilo Simic July 17, 2023

Just found out what the problem was.

The user has changed the default separator in his Excel which caused the problem. After reverting to the default ones, it all looked just fine.

Thank you everyone for the help, I never would have figured it out alone.

Andrei Ionut Sandu April 9, 2024

@Danilo Simic @Aron Gombas _Midori_ 

Hello,

 

I have this issue also but the separators are correct in Excel, period and comma. Also, the files are correctly opened from other apps but this Jira CSV current fields not.

 

any idea? thank you!

Suggest an answer

Log in or Sign up to answer