What's happening with Copy to Subtask?

When I try to open my "Copy to Subtask" plugin, I get this error:

Not Found (404)

/secure/views/plugins/copytosubtask_config.jsp

Could not find what you were looking for. Maybe you should raise an issue.

JIRA home

2 answers

1 accepted

1 vote

Have you installed the jsp files as well? There is a zip file that has 3 jsp files in it.

.Zip file? .Jsp file? No, I just clicked the Install button.

I just now looked at the site and tried he download button. All it offers to download is a .jar file.

I do now see the note about installing the .jsp files. I had to poke around on the site a lot, but finally found it and downloaded. We will see.

Thanks.

OK...Site says...

"Also download the file copytosubtask_config.jsp and copy it to the directory atlassian-jira/secure/admin/views"

So I copied it to here:

C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\admin\views

I then restarted JIRA. When I attempt to open the plugin I get the message below. Note that the path is DIFFERENT from the one the documentation said to use. In fact, there is no C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\views\Plugins folder.

------------------

Not Found (404)

/secure/views/plugins/copytosubtask_config.jsp

Could not find what you were looking for. Maybe you should raise an issue.

JIRA home

---------------------

So I created the folder and moved the plugin to it. Stopped/restarted JIRA. Got the same message again.

So, combining the error message with the directions, I tried putting it here:

C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\admin\views\Plugins

Same message.

The url that generates the message is

"http://localhost:8080/secure/admin/CopyToSubtaskConfig!default.jspa"

So, for chuckles and grins I tried dropping the plugin here:

C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\admin

Still no go.

CopyToSubtask is v3.1

JIRA is v5.1.7

See https://studio.plugins.atlassian.com/wiki/display/JCTS/Home. As mentioned, for v3.0 or higher,

Download the zip file from here and extract it to the directory atlassian-jira/secure/views. This will create a folder plugins with the jsp files under it.

Not sure why it created 2 plugins directory because the zip has only one level! Anyways, you finally has it working :)

Downloaded the .ZIP to here:

C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\views

Extracted it there, so this was created:

C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\views\plugins\plugins

C:\Program Files\Atlassian\JIRA\atlassian-jira\secure\views\plugins\_MACOSX

That didn't work, so moved them up one level.

And, YES, it is finally working.

Did get it working as described above. However, two facts have caused me to abandon it:

1. It won't handle the standard 'Description' field, which is the one I most wanted to copy.

2. It takes too long for the script to run each time.

I would have awarded more karma points for this, but it seems I can only give one.

Hard to say with just this information.

1) Is this a new installation?

2) If not, where did your data come from?

3) If a new installation, did you install the pluging?

4) If old installation, did someone remove the plugin?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

641 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you