Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,361
Community Members
 
Community Events
176
Community Groups

What is this madness? Filter say no project exist in filter...

I am fetching issues from the project as well as items in other projects that connect using a custom field...but for some reason I get this error:

"We can't show the projects on this board, because the board's filter doesn't specify any. Your users may have trouble managing issues and sprints on this board. Try including some projects in the filter to fix this."

 

This is the query:

project = CRM OR "Related System[Dropdown]" = CRM ORDER BY Rank ASC

 

Anyone see what the issue might be as the board does not seem to recognize the project?

 

2 answers

Hi @Jimi Wikman 

So you've set up this filter in your board. Did you check about the filter sharing? If this filter is set to private, then no-one will be able to see the results. Try sharing this filter with all roles in the project. This should do the trick (hopefully).

I wish that would work, but it seems you can no longer use OR without a specific project reference anymore.

I even tried giving everyone permission to manage sprints, but it does not matter.

No one that is not site admin can manage sprints with this query.

That's not what I mean @Jimi Wikman . First and foremost, the link you are sharing is for jira server, but your question is about jira cloud. You have to clarify if you are having an issue on jira server, or jira cloud.

Despite the above, when you create a board, you use a filter to do that. In your case this one:

project = CRM OR "Related System[Dropdown]" = CRM ORDER BY Rank ASC

If the above filter isn't share with the project, then they will not be able to see any issues on the board. Can you please provide any screenshot of your board, filter and filter share?

board.png

boardshare.png

Finally you mention something about managing sprints. Is this another question? I thought your problem was that specific message which appears on the board (would be great if you could share a screenshot of that message).

And if the above solution I mention doesn't work, please read this post https://community.atlassian.com/t5/Team-managed-projects-questions/Why-wont-my-board-show-projects-in-the-board-settings-when-i/qaq-p/1084144, because there could be just an error on your JQL. 

Jack Brickey Community Leader Apr 23, 2022

@Jimi Wikman , what results if you simply paste that filter into Advanced issue search? If that works as expected please share images f your board similar to what @Alex Koxaras _Relational_ presents here.

I appreciate the effort, but this change forces you to provide sprint functionality in every project to everyone.

The filter itself does not matter.

Adding ""Related System[Dropdown]" = CRM" act as a global query, meaning that unless you have sprint planning permission in all Jira projects it will disable that functionality in your board.

It does not matter if you don't even have issues in other Jira projects that trigger this query.

It's a mess and a very poor implementation that I hope someone has put up a technical debt for...

I ran into something similar. Another thing you may want to check is the project's permission scheme to ensure that you are able to search for the project within the project itself. 

>project settings > summary > make note of your project's scheme

>settings > Issues > permission schemes > select your project's scheme

in the Browse Projects section, confirm that there is a role associated with this item. Otherwise, the ability to browse within the project isn't possible. Ensure that the roles and access are configured correctly too. If not, click Update and change the settings.

Suggest an answer

Log in or Sign up to answer