Values disappear if edit.type is set to 1 (jira database values plugin)

Hey,

we have an external database which fills a customfield (by using the jira database values plugin). All works fine until we change the edit.type from zero to one (AJAX-style input field).

There are no suggestions if you typing something in.

Is there anyway to get it working as AJAX-style input field ?

8 answers

What version of JIRA and plugin are you using?

We are using JIRA 5.2.2 and the plugin version is 2.0

I encountered the same problem. It seems the ajax is not loaded correctly when opening the screen for the first time.

Try to close the screen an reopen it. It should be working then.

Regards

Constantin

Thanks for the answer. I tried it but it did not work for me. Still have the same problem (only for the ajax field).

I am having the same problem while upgrading the plugin from 1.4 to 2.0 with Jira 5.2. Any help will be greatly appreciated. Thanks.

We had the same issue. We had to go to "Create Issue" specifically where it would not work there, then we could go to create or edit issue for the dropdowns to work.

While investigating i checked the source of the page. For me when opening the edit screen the first time the following div is rendered

<div class="field-group">
<label for="customfield_10300">Ansprechpartner</label>
<input id="databasevalues_customfield_10300" name="_customfield_10300" class="ui-autocomplete-input" size="50" type="text" value="xxx">
<input type="hidden" id="databasevalues_hidden_customfield_10300" name="customfield_10300" value="44326">
</div>

when opening it up the second time the following div is rendered.

<div class="field-group">
<label for="customfield_10300">Ansprechpartner</label>
<input id="databasevalues_customfield_10300" name="_customfield_10300" class="ui-autocomplete-input" size="50" type="text" value="xxx" autocomplete="off" role="textbox" aria-autocomplete="list" aria-haspopup="true">
<input type="hidden" id="databasevalues_hidden_customfield_10300" name="customfield_10300" value="44326">
</div>

So it seems there is some difference when loading the edit screen for the firsttime.

Regards


Constantin

I just tested with JIRA 5.2.8 and it all seems to be working fine. Any chance that you can test with the 5.2.8 version?

Same Problem with JIRA 5.2.11

  • click "create new issue"
  • put some input in database field -> no auto-suggestions
  • cancel create screen
  • click again on "create new issue"
  • database field works now and everytime there after until you close browser window

There is also an issue for this:

https://bitbucket.org/wimdeblauwe/jdvp/issue/3/problem-with-starting-ajax-view-the-custom

I just released a version 3.0 that is compatible with JIRA 6. Could you try this version in a test instance to see if the issue is still there?

Is v.3 compatible with JIRA 5.2?

On marketplace.atlassian.com only JIRA 6 is marked as compatible to jdvp v.3.

I compiled it against 6.0, but most probably it will work with 5.2 as well, but I did not test it.

The problem still exists

And can you test with JIRA 6? That way I am sure the problem is in the plugin and not in JIRA itself?

With JIRA 6 there is also the same issue. On first try nothing happens, but works on second try.

Also tested on new installed and empty JIRA 6 (only jdvp plugin installed, one jdvp customfiled defined and using standard workflow and screens).

I'm having the same problem on JIRA 6, except it doesn't matter if it is the first, second, third, whatever try - I never see it if I use the AJAX-style input. I have to use the dropdown style. It wouldn't bother me so much, except I'm trying to use the custom field to search a parts database with ~60,000 parts in it. That's a bit much to ask users to scroll through...

Here is my config, just to be sure, everything is correct
(it was working without problems on JIRA 4.4.4)

database.driver=net.sourceforge.jtds.jdbc.Driver
database.connection.url=jdbc:jtds:sqlserver://********:1433/********
cache.timeout=14400000
sql.query=*******
primarykey.column.number=0
rendering.viewpattern={1} ({0})
rendering.editpattern={1} ({0})
rendering.searchpattern={1} ({0})
rendering.sortpattern={1}
edit.type=1
search.type=1
rendering.changelog.viewpattern={1} ({0})
rendering.statistics.viewpattern={1} ({0})

@Jason: you are probably having a different issue. I have it working fine. Maybe you might want to check the log files?

Hi Wim - Thanks for responding. Since my issue may be unrelated to this thread, I've started a new question that can be found here:

https://answers.atlassian.com/questions/176220/can-t-see-the-values-in-the-jdvp-custom-field-when-using-ajax-style-input-field

Is the problem still not resolved?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,309 views 12 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you