Upload add-on button missing (JIRA/Confluence)

Hello,

I have the latest JIRA software version 7.1 self-hosted. No matter what I do , I can t see the upload add-on button. We also have a previous 6.xx something version and on that , to see the upload button I had to disable marketplace.Atlassian.com access. I tried that on this version as well , but it did not work as intended. Can I have some help ?

EDIT1. When I go into Add-on setting , If i try to disable/enable Atlassian Marketplace I get this error: 

Error

Your request cannot be completed at this time.

Logs are not saying anything about this error. Any ideas?


2 answers

This widget could not be displayed.

Neither version should hide the upload add-on button, so there's a big question on what you have done to disable it.

Could you tell us exactly what versions of JIRA you are using?  The full version string from the bottom of the pages?

This is the entire string of the application:

Ok, that's good (I had feared you were using a Cloud download, which would kill the upload option)

But it does leave me a bit stuck - I don't know how to disable the upload function cleanly without causing errors that you'd see in the logs, except by logging in as a non-system admin.  Disabling the whole UPM will do it, but you've said that makes the option appear in 6.4 which is the opposite of what I get.

Could you check that all the modules in the UPM are fully enabled though? 

And how can I do that? I tried to replace UPM with latest version 2.20.7 .... same behavior. I reenabled the upm... Others ideas? I have adblock plus(saw there were some issues with the javascript executed), but I doubt that is the issue,  as I tried to disable, nothing being changed.

To check the modules, go to manage add-ons, find the upm and look to the right, it will say X modules of Y enabled (for most add-ons, X = Y, but not always).  Have a look at any disabled ones.

I really don't know how to get rid of "upload add-on" though, except by being on Cloud.

Unfortunately , I can't see any modules enabled, actually the right part that you are talking about, is completely missing from my installation.

test21.jpg

Your UPM appears to be broken.  I think you'll need to fix that first!  Have a look through the logs to see if there are errors in there to begin with.

The system doesn't log any errors on atlassian-jira.log nor catalina.out. The only problem I see is the connection to marketplace.Atlassian.com as I am behind a proxy and access to any internet sites has to be through the proxy( impossible at the moment for marketplace). 

Oh, one other thing that I didn't know until I ran into it a minute ago.

Could you have a look at your system information page and find the JVM input argument settings? It might be called something different on your system, depending on version, so here's the first couple of lines from the JIRA I'm looking at today - lots of the options will have -D or -X on the front of them: 

JVM Input Arguments -Djava.util.logging.config.file=/opt/jirahome/install/conf/logging.properties -Xms1024m -Xmx2048m -XX:MaxPermSize=512m

JVM Input Arguments-Djava.util.logging.config.file=/opt/atlassian/jira/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms2048m -Xmx2048m -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -XX:+PrintGCDateStamps -XX:-OmitStackTraceInFastThrow -Djava.endorsed.dirs=/opt/atlassian/jira/endorsed -Dcatalina.base=/opt/atlassian/jira -Dcatalina.home=/opt/atlassian/jira -Djava.io.tmpdir=/opt/atlassian/jira/temp

Ok, it's not what I ran into; there's a -D flag you can set that removes the "upload addon" function.

I'm afraid I have to go back to "your UPM is broken".  You've ruled out all the possible ways to disable the upload addon function, and there's nothing in the log, so I don't know what's wrong.  All I can think of to do next is increase logging in the UPM to "debug" level so you can see what it's doing - that might tell us a bit more.  Admin -> logging and profiling -> Configure logging level for another package and add com.atlassian.upm with "debug" level

I finally found the issue that was bugging the jira/confluence server.. Having an nginx proxying all requests, we let only methods POST/GET , but as we found out JIRA is using much more methods(eg. PUT), so we excluded that from the server. Thank you for your time and for your understanding

Ahh!  So the upm was being broken by a broken proxy!

Very well spotted, I'd have struggled to find that.

This widget could not be displayed.

You need to be logged on as Sysadmin

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

124 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you