It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Updated Exchange Certificate now Incoming Mail no longer works

We updated out Exchange Server Certificate on friday and now the incoming mail handler no longer works. I get the following error:

Unfortunately no connection was possible. Review the errors below and rectify:

  • SunCertPathBuilderException: unable to find valid certification path to requested target

I tried to use portecle and import the new cert into Java but this did nothing.

3 answers

I guess the real question is where are the certs stored I just need to update the cert

Hi @Troy Pawleska ,

You have to add the certificate  to the Jira keystore. Usally jira uses the keystore of the java that is coming with jira and is located here : $JAVA_HOME/lib/security/cacerts , password is changeit 

 

Here is also an related kb article https://confluence.atlassian.com/kb/how-to-import-a-public-ssl-certificate-into-a-jvm-867025849.html

So I added it to the cacerts file because I found several articles on that but it's still not working, I found the cacerts file in 2 locations so put it in both. 

 

C:\Program Files (x86)\Java\jre1.8.0_221\lib\security\cacerts

C:\Program Files\Atlassian\JIRA\jre\lib\security\cacerts

 

Am i putting it in the wrong location? How can I point Jira/Java to these cacerts files?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

303 views 1 3
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you