Update/Install failed?

I'm a bit new to JIRA install, first of all. BUT.

I got hands of JIRA 6.2 and I have to update it to latest since other versions are no longer available.

Current installation of JIRA (6.2) is currently running on Centos 6 server live (or as others might name it production). Fortunately is on a VMware VM so I can play with another snapshot of same machine. Tried update to 7.1.8 but it fails at the end of web configuration with errors regarding database indexing. I've looked on support and found that on version 6.4 update there are some issues with "Indexing failed after JIRA application upgrade with Reindex All FAILED error". Followed steps in resolving this database issue with the same result (web interface of JIRA unavailable after console update successful). Then re-cheked update process and after a bit of digging found that is better to update to 7.0 prior to 7.1 first. Same result.

Then I thought, maybe is better to have a fresh install and import setup from old 6.2 so:

question 1:  is it possible to port configuration and database from 6.2 to 7.1?

I've built a new centos 7 installation server with  PostgreSQL installed. For the moment no firewall. Installed JIRA 7.1.8 - started fine in console (no errors - installed on root, I had to chown folder /opt/Atlassian to jira:jira user full access to have errors from apache tomcat not being able to create some /opt/atlassian..../localhost folder dissapear). Still according to default installation presented on site: I should be able to access JIRA at this stage via browser on any PC in same subnet with http://IP_OF_JIRA_SERVER:8080. This does not happen.

I've checked and I have JIRA process listening on tcp protocol on 0.0.0.0:8080 (not on tcp6!!!). I also was able to telnet from local server on both 127.0.0.1:8080 and ip_of_jira_server:8080. 

question 2: What did I do wrong? or is there a internal http restriction that I cannot see?

Thanks for support. (I also mention that current installed JIRA is acquired with license. 

3 answers

0 vote

In the second case, what does the log say?  And what does the browser say when you try the ip:8080 address? 

First: I was wrong about firewall. It was on. Centos 7 has a different management system regarding firewall rules (firewall-cmd). For testing purpose I just disabled it in order to finish JIRA installation. I got now a working 7.1.8 installation. I just started a restore from a back-up of 6.2 version and now I just got confirmation that import was successful.

 

In second case jira/catalina logs did not show anything and that led me to believe that there is still something blocking access to 8080 port. So I returned to network/firewall setup, maybe I missed something. It turned out that I did. Honestly - I admit I was a bit mislead by installing ssh service. When I installed ssh daemon I did not setup any firewall rules and I was able to access test server via ssh without additional setup. Also in OS install there was no firewall setup. After issue with JIRA 8080 access, I tested with ftp installer. I installed ftp and behaved the same as JIRA -> no access after install. Then I restarted checking firewall and discovered it was the "killer".

Also I got answer now for the first issue: I was able to import back-up from 6.2 into 7.1.8 with success.  

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

138 views 0 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you